05 Silverado Drivers Side Heater Problem - Chevrolet Forum - Chevy Enthusiasts Forums

05 Silverado Drivers Side Heater Problem


  Reply  
Join Date: Nov 2008
Posts: 2

November 11th, 2008, 8:40 PM   #1  
05 Silverado Drivers Side Heater Problem

The drivers side heater on a dual control climate system isn't working. The cooling is working fine. Also both heat and cooling is working fine on the passenger side. Any ideas ?

 
jkgray80's Avatar
Senior Member

Join Date: Mar 2008
Posts: 158

November 13th, 2008, 9:58 PM   #2  
RE: 05 Silverado Drivers Side Heater Problem

Changed or disconnected battery recently? Sounds like HVAC lost program. Need tech2 to relearn it.

 
Join Date: Nov 2008
Posts: 2

November 15th, 2008, 9:46 PM   #3  
RE: 05 Silverado Drivers Side Heater Problem

No, the battery has never been disconnected since I bought the truck new. Also the light on the driver side temperature control module isn't working, it is dark and the passenger side controller is still lit up. I am not sure if this is a burned out bulb or a something associated with the temp controller not working. I will disconnect the battery tomorrow and see if it fixes it. Thanks for the reply !

 
thedogg7's Avatar
CF Beginner

Join Date: Sep 2010
Posts: 4

September 21st, 2010, 8:16 PM   #4  
I know this is an old post, but i have the same problem same year. Dual zone, passenger side blows warm and cold but the driver side only blows cold. Any ideas?

 
Lazz's Avatar
CF Beginner

Join Date: Sep 2010
Posts: 1

September 27th, 2010, 10:04 PM   #5  
Same here

Would love to get this fixed

Any ideas?

 
thedogg7's Avatar
CF Beginner

Join Date: Sep 2010
Posts: 4

September 28th, 2010, 10:06 AM   #6  
lazz,

this might help you out. i got mine working this week. i dont think my blend door actuator was bad, i think it was maybe stuck or possibly starting to go bad. i found the location of three actuators in my truck. is yours dual zone as well?

 
thedogg7's Avatar
CF Beginner

Join Date: Sep 2010
Posts: 4

September 28th, 2010, 2:18 PM   #7  
at any rate, this is what i did. (you'll probably need 7mm & 5.5 mm or the closest standard equivalent, tiny slotted screwdriver, large slotted screw driver for prying, some configuration of extensions, swivels, adapters. i took the black plastic kick plate off from under the dash. i think i had to use a swivel at one point and a 3/8 drive w/ 1/4" adapter because the extension for the 1/4" drive was too long. when you get it removed, you can see the blower motor (bosch) on the far right of the passenger side and its resistor (mine needed replaced because the fan only worked on "5"). You might also have to remove the duct work extension to the passenger side, but it just slides off.

the blend door actuator for the driver side is located just above the corner of the tranny hump on the passenger side. it is mounted to the bottom of the shiny black duct work. you should be able to see the black and red wires on the pigtail that plugs into it. it also has a red clip holding the pigtail in place. <O></O>
<O></O>
the blend door actuator for the passenger side is mounted on top of the duct work directly above the driver's blend door actuator. access to it requires the removal of the glove compartment panel and possibly other dash panels. <O></O>
<O></O>
the mode door actuator is located on the drivers side way up in the dash above the corner of tranny hump. is it mounted on it's side. This is probably not your problem if you trouble is similar to mine, but it's good for reference.<O></O>
<O></O>
At this point, hopefully you are in a quiet place. i put the truck in accessory, turned the fan off and moved the passenger temp control from hot to cold or vice versa. you should be able to hear the actuator motor spinning. listen closely, it's hard to hear. try the driver's side actuator. mine didn't make any noise so i removed the driver's side actuator by unplugging the pigtail, removing the the two mounting screws (gold, 5.5mm), and wiggling it back and forth. the actuator has a hole through the middle of it, connected to a gear inside, that sits on a post. basically, several plastic gears turn inside it, and rotate the hole which has two flat spots to grip the post. the hole moves the post which is connected to the bottom part of the blend door. When you remove the actuator, you will be able to turn the post by hand, and you should hear the blend door moving inside the duct work. If you canít it is stuck and you need to try and free it up. I then used a small slotted screw driver to pry open the actuator. Everything in mine looked good. The gears werenít stripped and nothing looked burnt. I pulled one of the plastic gears out (the one contacting the black one that turns the ďholeĒ ). I repositioned the black gear a little bit. Youíll notice is has two contacts that slide along a circuit board. (Circuit boards are like magic to me.) To me, it looked like possibly those contacts slid off the board. With cover off, I used two small wires and the truck battery to test the actuator. Mine was spinning freely. I decided to hook the actuator back up and see what happened. You may have to reposition the black gear to get the hole and the post to line up. If your actuator isnít working or you donít feel like messing with it, a new actuator is about $155. Once I determined that actuator seemed to be functioning ok when I moved the temp control, I decided I would leave the kick panel off for now. If it quit working again, as a cheap fix, I would take the actuator off again and turn the blend door by hand to hot for the winter. When you think about it, thereíre an awful lot of moving parts, switches, circuit boards and a motor to open and close one stupid little door. <O></O>
<O> </O>
Hopefully I helped you more than confused you. I promise itíll make much more sense when youíre looking at it. Sorry for the lengthy explanation. I know a lot of my terminology especially with the actuator probably isnít what these parts are technically called, but Iím not really a car guy, I was just cold. let me know if you have any questions or need a picture of something. good luck.

 
guvner's Avatar
CF Active Member

Join Date: Sep 2007
Posts: 226
Ofallon, Missouri

November 2nd, 2010, 12:41 AM   #8  
I have a 2004 Silverado, 2500HD w/Crew cab and 6 litre engine. My left side mixer isn't doing much. I have nothing but heat coming out while my passenger side is perfectly happy so I'm presuming my mixer is having an issue.

I probably should have read your first paragraph before commenting... Sorry...

Thanks... Gary


Last edited by guvner; November 2nd, 2010 at 10:01 AM. Reason: Poor reading skills.. Had to remove some stupid observations I made.. :(
 
thedogg7's Avatar
CF Beginner

Join Date: Sep 2010
Posts: 4

November 2nd, 2010, 8:27 AM   #9  
I'm assuming that you have dual climate. I would say your driver side blend door actuator is bad or stuck. I would take the black plastic cover off under the dash, shut the driver side door, lean in on the floor from the pass side, turn the truck in accessory and move climate control for one side at a time. You should be able to hear the electric motor spinning in the actuator. Listen closely. If the passenger side is working it'll give you a good idea of what you're listening for. I would guess you actuator is mounted somewhere close to where mine are (see my above post). Let me know what you find out.

 
YUKON1219's Avatar
CF Beginner

Join Date: Dec 2010
Posts: 1
Thunder Bay ON.

December 6th, 2010, 9:24 AM   #10  
How do you remove the radio and dash in 2004 gmc yukon with daul zone climate control

 
Tags
Search this Thread
Sponsors
Related Topics