Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevy Trucks, SUV's, Crossovers & Vans > Avalanche
Sign in using an external account
Register Forgot Password?
Search

Avalanche Chevy's first real SUT, combining the interior room of an SUV and the cargo ability of a pickup truck.

Chevrolet Avalanche
Platform: GMT 805 & 900.

Reply
 
 
 
 
LinkBack Thread Tools
  #1  
Old 02-01-2011, 07:51 PM
CF Beginner
 
Join Date: Sep 2008
Posts: 5
Default '07 Avalanche turn signal problem

my 07 avalanche right turn signal has gone haywire. Blinks normal about 4 times then starts blinking very fast. Front, Mirror and Rear bulbs all blinking. HELP!!!! Can someone tell me where the signal flasher module is located?
Register today for free or log-in if already registered to remove this ad!

Last edited by mudslide; 02-02-2011 at 06:14 PM.
Reply With Quote
  #2  
Old 02-02-2011, 10:46 AM
CF Beginner
 
Join Date: Jan 2011
Location: Florida
Posts: 16
Default

Sounds like one of the bulbs may be out and its telling you to check them auto window tinting hillsboro oregon

Last edited by Drew82; 10-21-2011 at 05:00 PM.
Reply With Quote
  #3  
Old 02-02-2011, 02:36 PM
CF Beginner
 
Join Date: Sep 2008
Posts: 5
Default

negative...all bulbs working...does anyone know where flasher is located?
Reply With Quote
  #4  
Old 10-24-2011, 04:31 PM
CF Beginner
 
Join Date: Oct 2011
Posts: 1
Default

I have the same problem with a 07 tahoe.
Reply With Quote
  #5  
Old 10-24-2011, 06:23 PM
CF Veteran
 
Join Date: Mar 2011
Posts: 1,706
Default

Welcome to the forum. The BCM handles the turn signals on yours. It will hyper-flash the side if there's something wrong with the circuit, like something limiting the current flow (bulb out, too light a load, etc.). Look for a bulb that doesn't light up or lights up dim. Also, if you have replaced a normal bulb with an LED bulb, that'd be the problem.
Reply With Quote
  #6  
Old 10-28-2011, 07:16 PM
AVArookie's Avatar
CF Beginner
 
Join Date: Oct 2011
Posts: 14
Default

I just had a similar problem with my 2003. R.R. turn signal would not work, checked the bulb all was fine. Fronts stayed working correctly. It ended up being a simple fix. On the 2003 there is a power module behind the r.r. tire, mounted underneath the bed, to the inner of the quarter panel. If your is similar, look up under your Av. You can't miss it, it will have 5 different plugs to it. They each control a different section of lighting and such to the rear of the Av.. I had just recently replaced this module due to the running lights stopped working on the r.r.. Turn signal, stop lights worked fine. It seems I did not push the bottom plug in all the way or something, as soon as I pushed it in, the turn signal woks fine. Hope this helps.
Reply With Quote
Old 10-28-2011, 07:16 PM
 
 
 
Reply

Tags
2008, 2011, avalanche, blinking, blinks, fast, flasher, location, module, problem, problems, relay, signal, start, turn, turning


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Join Chevroletforum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 04:50 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup