Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevy Trucks, SUV's, Crossovers & Vans > Avalanche
Sign in using an external account
Register Forgot Password?
Search

Avalanche Chevy's first real SUT, combining the interior room of an SUV and the cargo ability of a pickup truck.

Chevrolet Avalanche
Platform: GMT 805 & 900.

Reply
 
 
 
 
LinkBack Thread Tools
  #1  
Old 01-02-2012, 04:43 PM
CF Beginner
 
Join Date: Jan 2012
Location: American Canyon
Posts: 2
Default radio problems

I have a 04 Avalanche, the radio speakers in the back stopped working then the passenger door speaker stopped working this was in a time frame of about a month, the drivers door still works to this day I thought it was the radio [ delco mid grade same as what was in it] and replaced it with another good used one and still have the same problem, I was told it may be the amp, I cant find a amp neither under the center console or behind the glove box. Any help ?? I tried replacing the passenger door speaker and nothing, just a light sound from the tweeter with the balance all the way to the right and the volume cranked up. Im lost on this one fellas????????????????????
Register today for free or log-in if already registered to remove this ad!

Last edited by BigDog60; 01-02-2012 at 05:50 PM.
Reply With Quote
  #2  
Old 01-26-2012, 08:28 AM
CF Beginner
 
Join Date: Jan 2012
Posts: 5
Default radio not working

I have an 08 Aval....same problem with front speakers...did you find out what was wrong....?
Reply With Quote
  #3  
Old 01-26-2012, 12:43 PM
Official GM Rep
 
Join Date: Mar 2010
Location: Michigan
Posts: 3,606
GMLouisFischer
Default

lv2play & BigDog60,

This could be a wiring issue, wiring short possibility. This is not a diagnosis, just a suggestion. I encourage you to have the vehicle inspected by a certified technician. A certified technician should be able to offer a more accurate diagnosis with a physical inspection.

Please keep us posted.

If you have additional questions, please feel free to contact me.

Louis
GM Customer Service
Reply With Quote
  #4  
Old 01-27-2012, 07:53 AM
CF Beginner
 
Join Date: Jan 2012
Location: American Canyon
Posts: 2
Default

Check by the emergency brake to make sure the wires are not cut by the ratchet from the emergency brake, I was told this is a common problem. Also I had bad speakers, tried a couple on it and they were bad also so I took one out of my truck and hooked it up and they worked.
Reply With Quote
  #5  
Old 11-18-2012, 08:22 PM
CF Beginner
 
Join Date: Nov 2012
Location: Montreal, Canada
Posts: 3
Default

I have the same problem with my front driver door speaker (08 Avy LT not bose)
Reply With Quote
  #6  
Old 12-13-2012, 09:32 AM
CF Beginner
 
Join Date: Dec 2012
Posts: 10
Default

First Visually check all your fuses. Does rig have amp for stereo by any chance? It sounds like amp is bad and/or fuse is blown.
Reply With Quote
  #7  
Old 12-14-2012, 04:05 PM
CF Beginner
 
Join Date: Nov 2012
Location: Montreal, Canada
Posts: 3
Default

Quote:
Originally Posted by Retcher View Post
First Visually check all your fuses. Does rig have amp for stereo by any chance? It sounds like amp is bad and/or fuse is blown.

No amp
Reply With Quote
  #8  
Old 02-06-2014, 03:47 PM
CF Beginner
 
Join Date: Feb 2014
Posts: 1
Default

Ever find out what the root cause was? I have an 04 with the same issues. Back speaker was working but now all that works is the front tweeters. Replace head unit? Wiring? Fuse?
Reply With Quote
  #9  
Old 02-07-2014, 08:13 AM
CF Beginner
 
Join Date: Jan 2012
Posts: 5
Default

My 2008 had the same problem.........it's the speakers....I replaced all the speakers and it works fine.....it is very simple...I watched a video on youtube about taking off the door panels,,,first one took 45 minutes to remove and replace the speaker and panel....the rest....15 minutes a door...simple......I replaced with Pioneers and they sound great.....
Reply With Quote
  #10  
Old 02-11-2014, 04:16 PM
Susie's Avatar
CF Beginner
 
Join Date: Feb 2014
Posts: 1
Unhappy 08 Avalanche Radio problems...locks too

I too just took my Avalanche to the mechanic, he says that both front and back door speakers need to be replaced , but they also work intermittently. Now I read that others with the same issue replace with no improvement....I think it's time to get rid of this thing...the door locks quit 3 years ago...work intermittent also...think there's a electronics issue with this truck...
Reply With Quote
Old 02-11-2014, 04:16 PM
 
 
 
Reply

Tags
02, 04, alanche, avalanche, chevorlet, drivers, quit, radio, rear, shooting, speakers, trouble, truck, work, working


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Join Chevroletforum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 08:06 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup