Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevy Trucks, SUV's, Crossovers & Vans > Avalanche
Sign in using an external account
Register Forgot Password?
Search

Avalanche Chevy's first real SUT, combining the interior room of an SUV and the cargo ability of a pickup truck.

Chevrolet Avalanche
Platform: GMT 805 & 900.

Welcome to Chevrolet forum!
Welcome to Chevrolet forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Chevrolet forum today!


Reply
 
 
 
 
LinkBack Thread Tools
  #1  
Old 12-05-2012, 03:36 PM
CF Beginner
 
Join Date: Dec 2009
Posts: 4
Default service brake booster

2003 avalanche 170K on odometer getting service brake booster on Instrument cluster where the odometer reading should be. This only started after the alternator failed. Replaced alt got rid of that not charging message but can't get rid of the service brake booster message. I have replaced the aux vacuum pump attached to the brake booster. Still getting message but only comes up after you touch the brakes the first time after a restart. Had instrument cluster repaired in Aug but message didn't come up until alt failure at thanksgiving. Any ideas on how to trouble shoot this / fix this.

Problem fixed this is an FYI the new alternator wasn't right it would charge the vehicle fine but it wasn't producing 12 volts on the p pin (dark blue wire) of the plug on the top of the alt. the supplemental brake assist pump has to have that 12 volts in order to operate. It is what tells the pump that the engine is running. Put another alt on. The 12 volts was on that pin and the message has not come back. That line goes directly to the SBA pump no where else. and on most vehicles it is not used.
Register today for free or log-in if already registered to remove this ad!

Last edited by wtroger; 12-13-2012 at 10:26 AM. Reason: problem fixed
Reply With Quote
Old 12-05-2012, 03:36 PM
 
 
 
Reply

Tags
2003, auxilary, auxiliary, avalanch, avalanche, booster, brake, chevrolet, chevy, hot, pump, rid, service, test, truck, vacuum


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 11:02 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup