Trouble Code PO121 - Chevrolet Forum - Chevy Enthusiasts Forums

Trouble Code PO121


  Reply  
Join Date: Sep 2008
Posts: 5

February 13th, 2012, 12:37 PM   #1  
CF Beginner
Trouble Code PO121

Check engine light comes on and stays on for a day or two, then goes off. Showing trouble code PO121 (throttle position sensor). When the light is on, remote start won't work. Help, mudslide

 
Join Date: Mar 2010
Posts: 4,070
Global Headquarters in Detroit, MI

February 13th, 2012, 9:41 PM   #2  
Official GM Rep
<!--[if gte mso 9]><xml> <w:WordDocument> <w:View>Normal</w:View> <w:Zoom>0</w:Zoom> <w:PunctuationKerning/> <w:ValidateAgainstSchemas/> <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid> <w:IgnoreMixedContent>false</w:IgnoreMixedContent> <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText> <w:Compatibility> <w:BreakWrappedTables/> <w:SnapToGridInCell/> <w:WrapTextWithPunct/> <w:UseAsianBreakRules/> <wontGrowAutofit/> </w:Compatibility> <w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel> </w:WordDocument> </xml><![endif]--><!--[if gte mso 9]><xml> <w:LatentStyles DefLockedState="false" LatentStyleCount="156"> </w:LatentStyles> </xml><![endif]--><!--[if gte mso 10]> <style> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} </style> <![endif]--> mudslide,

Could you please provide additional information? Vehicle model and year? How long has this been occurring? Is this a recent issue or a recurring?

Any additional information you can provide may help.

Louis
GM Customer Service

 
Join Date: Sep 2008
Posts: 5

February 18th, 2012, 12:23 PM   #3  
CF Beginner
'07 Cheveolet Avalanche LT 4WD. The check engine light has been coming on and going off every day or two for more than a month.

 
Join Date: Mar 2010
Posts: 4,070
Global Headquarters in Detroit, MI

February 21st, 2012, 3:18 PM   #4  
Official GM Rep
<!--[if gte mso 9]><xml> <w:WordDocument> <w:View>Normal</w:View> <w:Zoom>0</w:Zoom> <w:PunctuationKerning/> <w:ValidateAgainstSchemas/> <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid> <w:IgnoreMixedContent>false</w:IgnoreMixedContent> <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText> <w:Compatibility> <w:BreakWrappedTables/> <w:SnapToGridInCell/> <w:WrapTextWithPunct/> <w:UseAsianBreakRules/> <wontGrowAutofit/> </w:Compatibility> <w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel> </w:WordDocument> </xml><![endif]--><!--[if gte mso 9]><xml> <w:LatentStyles DefLockedState="false" LatentStyleCount="156"> </w:LatentStyles> </xml><![endif]--><!--[if gte mso 10]> <style> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} </style> <![endif]--> mudslide,

I have searched my resources, however, have been unable to find any known throttle position sensor or remote start issues with 2007 Avalanche vehicles. I encourage you to take the vehicle in for an inspection. A certified technician should be able to offer a diagnosis.

If you have any additional questions, please feel free to contact me.

Louis
GM Customer Service

 
Tags
Search this Thread
Sponsors
Related Topics