1996 cavalier theft light on no start - Chevrolet Forum - Chevy Enthusiasts Forums

1996 cavalier theft light on no start


  Reply  
hoghollow's Avatar
CF Beginner

Join Date: Jan 2010
Posts: 1

January 18th, 2010, 7:06 PM   #1  
1996 cavalier theft light on no start

1996 cavalier theft light is on not flashing but stays on. Car will not start have already changed fuel pump because the pump did not run when key was turned on. We did not notice the anti theft light being on. New pump does not run either. Have left key on for up to half hour light will not go out or blink. Any ideas or help thanks

 
todds96cav's Avatar
CF Beginner

Join Date: Oct 2009
Posts: 11

January 19th, 2010, 12:31 AM   #2  
Have you checked all your fuses and relays? Maybe unhook your battery overnight and see if it resets the anti theft device.

 
vortec02's Avatar
CF Beginner

Join Date: Mar 2010
Posts: 20
syracuse, NY

March 6th, 2010, 5:07 PM   #3  
Posted By: hoghollow 1996 cavalier theft light is on not flashing but stays on. Car will not start have already changed fuel pump because the pump did not run when key was turned on. We did not notice the anti theft light being on. New pump does not run either. Have left key on for up to half hour light will not go out or blink. Any ideas or help thanks
think i may be having the same problem on my 99 z24. theft light on and no power to the fuel pump, or the fuel pump relay. just one thing i have that you may have left out. when you turn the key to the on position, does the check engine light stay on like it should? mine doesnt. if you found your problem, could you let me know what it was.

 
dagreyon's Avatar
CF Beginner

Join Date: Nov 2011
Posts: 1

November 10th, 2011, 10:18 AM   #4  
1996 cavalier theft light O.o

I replaced my illuminator I believe thats what its called...It shows the temp speed rpm gas levels. Well i replaced mines because i wanted 1 with rpms once i replaced it my theft light came on currently i have the battery unhooked and when i get home from work ill hook it back up but im pretty sure it will still be there O.o how do i get that stupid theft light off so i can drive again >_<

 
kevinkpk's Avatar
CF Addict

Join Date: Jul 2011
Posts: 2,654

November 10th, 2011, 11:45 AM   #5  
Posted By: todds96cav Have you checked all your fuses and relays? Maybe unhook your battery overnight and see if it resets the anti theft device.
Yes. If the anti-theft fuse is open, blown, it will not start. The fuel pump won't come on with anti-theft on. What has changed? You might try turn on the key switch for about 10 minutes, then off, then try to start it.

 
binzer's Avatar
CF Beginner

Join Date: Apr 2009
Posts: 18
Pittsburgh, PA

November 11th, 2011, 9:56 PM   #6  
Posted By: dagreyon I replaced my illuminator I believe thats what its called...It shows the temp speed rpm gas levels. Well i replaced mines because i wanted 1 with rpms once i replaced it my theft light came on currently i have the battery unhooked and when i get home from work ill hook it back up but im pretty sure it will still be there O.o how do i get that stupid theft light off so i can drive again >_<
I believe you mean your instrument cluster.
Take a look at this link for instructions as to how to get your theft system to relearn...

FAQ - j-body.org - the jbody organization

 
Tags
Search this Thread
Sponsors
Related Topics