2004 Chevy Colorado Z71, Issues, need feedback - Chevrolet Forum - Chevy Enthusiasts Forums

2004 Chevy Colorado Z71, Issues, need feedback


  Reply  
MattL9's Avatar
CF Beginner

Join Date: Jan 2017
Posts: 1

January 22nd, 2017, 1:19 PM   #1  
2004 Chevy Colorado Z71, Issues, need feedback

What's up everybody? Just a heads up, I'm no car/truck mechanic. My specialty is with motorcycles so chances are a lot of what I'm going to say issuing to sound stupid. Forgive me.
I have a 2004 Chevy Colorado Z71 crew cab that I bought last October. I've been having some issues recently. So when I first bought it, I was told it would need new tires. Stopped at the local Belle Tire and they told me I would need a new tie rod and two need ball joints (1 per side). They were going to charge me $700 to do just that. Luckily, my old man's a mechanic and we did all the ball joints, tie rods, front brakes, rotors, wheel hubs/ABS sensors for a little over $500. A week after changing the wheel hubs, the passenger side wheel hub was supposedly bad. Got a new one under warranty and changed it out and it was good to go for a week. The light is back on again.
I also have problems with the eval system. Working on getting that fixed.
Just today, I've been having issues with the door. The "doors" light came on on my dashboard and the dome light came on while I was driving. Whenever I hit the lock button, it locks then unlocks right away. Any idea what could be wrong with this?
I have no idea what's going on with this stuff and I'm really getting sick of my dashboard looking like a Christmas tree so any advice would be greatly appreciated.

 
Tags
Search this Thread
Sponsors