Stabilitrak Off Message + lost Power stearing - Page 3 - Chevrolet Forum - Chevy Enthusiasts Forums

Stabilitrak Off Message + lost Power stearing


  Reply  
  #21  
Old  May 23rd, 2011, 8:44 AM
Wayneof North carolina 
I have a 2007 Equinox and have had no problems with steering or electrical until today. I parked the car and when I started it to back from the parking spot I had no power steering. I was able to manhandle the car out of the spot and onto the road, I was a couple of miles up the road before the "service stabilitrek" light came on. Nothing I do has any effect on getting the power steering working or the service light off. Any suggestions?
Wayneof north carolina,

I am sorry to hear that you are experiencing issues with your Equinox. Did you speak with the dealership about the issue? If so, did you get the issue fixed?

Thank you!

Elizabeth, Chevrolet Customer Service

  #22  
Old  May 29th, 2011, 4:48 AM
Service Stabilitrack FIXED @!@!$%#!!

OK so i found out that my EGR (exhaust gas recirc)valve was stuck open and was recirculating exhaust back to the engine so it had reduced torch. the stabilitrack automatically shuts off due to reduced power from engine. me and my wife replaced the EGR valve and gasket ($70 @ Auto Zone) in our garage and when we reconnected the battery cables all errors were clear!!! and have been for a week and the equinox runs way smoother and better on gas. Thank you ONSTAR diagnostics! if you have any questions email.

  #23  
Old  June 15th, 2011, 6:24 PM
  • CF Beginner
    Join Date: Jun 2011
    Posts: 3
Equinox Owner 
The 80 Amp Mega fuse is located under the hood compartment of your vehicle and it is number 63 block. I do have the 80 Amp Fuse if anyone needs one, I had to purchase several from company to get since dealership could not get it and did nothing to find out how to acquire one from outside of area.
I want to know how to replace it. How much does this fuse cost? Do I just unhook the battery and then pull it out? Because this is hooked into the terminal, right?

  #24  
Old  July 24th, 2011, 8:38 PM
Lost power steering

I attempted to jump a vehicle yesterday. When I backed away, I got the error message AND lost my power steering. THAT was exciting. I am hoping I can find an 80-amp Mega Fuse for block 63.

  #25  
Old  July 25th, 2011, 5:26 AM
  • CF Beginner
    Join Date: Jun 2011
    Posts: 3
no power steering, loses power

My problem I later found out was my transmission control module. It was a 900 dollar fix... Luckily for me it was covered under the powertrain warranty

  #26  
Old  July 26th, 2011, 4:17 PM
found the fuse!

Fortunately, the local Chevy dealer had the Mega 80 fuse. It set me back $18.70, and I replaced it myself easily. I was tired of driving a tank, steering-wise! Thanks for the great advice!

For those not sure, block 63 for the fuse is the one between the terminals. You have to remove the bolts and wires to take the fuse out. Five minutes maximum.

  #27  
Old  June 29th, 2012, 12:41 AM
  • CF Beginner
    Join Date: Jun 2012
    Posts: 1
I need a 80 AMP mega fuse for my (EPS) 08 Chevy Equinox - where can I get one and how much does it cost...... I know this is the resolution to my (no) power steering issue but no one has one right now.... I cant keep driving my vehicle like this - my arms hurt...

  #28  
Old  June 29th, 2012, 7:41 AM
KNivison 
I need a 80 AMP mega fuse for my (EPS) 08 Chevy Equinox - where can I get one and how much does it cost...... I know this is the resolution to my (no) power steering issue but no one has one right now.... I cant keep driving my vehicle like this - my arms hurt...
<!--[if gte mso 9]><xml> <w:WordDocument> <w:View>Normal</w:View> <w:Zoom>0</w:Zoom> <w:PunctuationKerning/> <w:ValidateAgainstSchemas/> <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid> <w:IgnoreMixedContent>false</w:IgnoreMixedContent> <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText> <w:Compatibility> <w:BreakWrappedTables/> <w:SnapToGridInCell/> <w:WrapTextWithPunct/> <w:UseAsianBreakRules/> <wontGrowAutofit/> </w:Compatibility> <w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel> </w:WordDocument> </xml><![endif]--><!--[if gte mso 9]><xml> <w:LatentStyles DefLockedState="false" LatentStyleCount="156"> </w:LatentStyles> </xml><![endif]--><!--[if gte mso 10]> <style> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} </style> <![endif]--> I recommend contacting your local dealer, they should be able to get one for you. Amazon.com* is another option, just make sure that the fuse will fit your vehicle.

*General Motors neither endorses nor maintains these sites and will not be responsible for any of its contents.

Louis
GM Customer Service

  #29  
Old  June 29th, 2012, 8:29 PM
  • CF Beginner
    Join Date: Jun 2011
    Posts: 3
Reply to Stabilitrak off...

I thought it could be a fuse, so I replaced the big fuse on the top of the engine like the manual said... but My real problem was a chip that went out.... It is covered if youre still in warranty and luckily I was but if the fuse replacement isnt what works for you, take it in.

Good Luck

  #30  
Old  August 19th, 2012, 1:43 PM
  • CF Beginner
    Join Date: Aug 2012
    Posts: 2
I can not find this Fuse!! any suggestions?

Gave a jump with my 08 equinox now my 80 amp fuse needs replacing...no one carrys it? Anyone know where to get one specifically?


  Reply
Tags
Search this Thread
Sponsors