Chevy 350 starting problems - Chevrolet Forum - Chevy Enthusiasts Forums

Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevy Trucks, SUV's, Crossovers & Vans > Express & G-Series Vans
Log In 

Express & G-Series Vans Offered in both a full size van, or a large box truck, the Express is the modern GM workhorse

Chevrolet Express
Platform: GMT Van

LinkBack Thread Tools Search this Thread
Old 10-24-2009, 11:53 AM
CF Beginner
Join Date: Oct 2009
Posts: 1
Default Chevy 350 starting problems

hi all, I have never been so desperate for ideas of what to check on my broken chevy

I will list what I know or think...

1984 RV _ G30 with a 350 Chevy engine. HEI ignition, Rochester Carb.

The van ran well back in September.. once it got hot it was running ok, cold starts were interesting... anyway, after a 100 mile journey, during the last 1/2 mile I noticed a fuel smell.. also, when the van was parked up, it 'ran-on' for the first time ever.. the temp was fine.

now I cannot get it to restart

I have checked the following
Compression - it is as it was a year ago, 150psi cold on all 8.
The carb has been off about 8 times, I cannot find anything obviously wrong.. I have checked float heights, compressed air through tubes, adjusted the electric choke it now has.. etc etc..

I have brought a known good HEi coil, and also the signal coil that triggers the main coil.. I really thought I had fixed it with that, last week it ran really well for about 20 mins, never been better...

but today, it did that and now has gone back to non starting again..

I have replaced plugs, rotor, distributor cap with new

I have checked the return fuel line is clear, and that the right amount of fuel is coming from the pump..

I beleive all Vac systems and being used or blocked..

It wont start, and when it did a little while ago, it threw a fair amount of vapour out of the carb...

so, it has fuel, compression, sparks, firing order correct, new coils and other electrical bits, choke is electric and the exhaust flange/cold start system ?EFE? is all back on and working..

what can I check now ? really stuck

John , England
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
350 having trouble starting and running. Camero-mike General Tech 6 04-28-2013 09:53 PM
For Sale: 1966 Pontiac Tempest,350 Chevy,turbo 350 ccnchevroletforum PRIVATE For Sale / Trade Classifieds 0 06-21-2012 03:43 PM
350 TBI Starting Problems seankeppers Silverado & Fullsize Pick-ups 1 01-29-2009 11:56 PM
Hard starting - 99 Tahoe Vortec 350 hardwarz Tahoe & Suburban 4 10-16-2007 12:54 PM

1984, 350, chevy, coil, cold, firing, hot, ignition, location, order, problem, problems, rv, start, starter, starting, time, uplander

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -5. The time now is 11:33 PM.