Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevrolet Car Models > Impala
Sign in using an external account
Register Forgot Password?
Search

Impala While undergoing many facelifts in its history, the Impala has proved itself to both civilians and police forces as one of the most capable 4-door cars GM has ever offered. Currently moving towards its 10th generation the Impala is one of the longest lasting and popular models.

2014 Chevrolet Impala
Includes: Bel-air
Platform: B-body & W-body

Welcome to Chevrolet forum!
Welcome to Chevrolet forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Chevrolet forum today!


Reply
 
 
 
 
LinkBack Thread Tools
  #1  
Old 10-05-2012, 02:23 PM
CF Beginner
 
Join Date: Oct 2012
Posts: 1
Default Turn key and nothing happens.

I have a 2003 Impala.When I turn the key,dashboard lights and everything comes on but the engine doesn't turn. It may happen once a day or once a week or even several weeks. Battery checks good.
I am open to any suggestions.
Thanks for your help.


Please Help!
John B.
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 10-05-2012, 11:16 PM
CF Junior Member
 
Join Date: Sep 2012
Posts: 98
Default

Before condeming any parts make sure your battery cables are tight & free of corrosion @ the starter & ground.
Reply With Quote
  #3  
Old 10-06-2012, 07:22 PM
CF Beginner
 
Join Date: Oct 2012
Posts: 2
Default

Im having the same problem in my 2011. All the lights on the dash are lite and when i turn the key to start everything goes dead, no fuel pump, I can just hear some relays under the dash. This didnt happen over a period of time or give me any warning lights. I started the car and drove it in the morning started it up drove home went to use later that day and no start checked the battery and it read 9v. Replaced battery and still no start. Checked the started and its good, when key is turned to start no voltage to the solenoid wire. I'll tell you if I find out whats wrong.
Reply With Quote
  #4  
Old 10-09-2012, 10:33 AM
Official GM Rep
 
Join Date: Mar 2010
Location: Michigan
Posts: 3,395
GMLouisFischer
Default

Quote:
Originally Posted by tomyear1 View Post
Im having the same problem in my 2011. All the lights on the dash are lite and when i turn the key to start everything goes dead, no fuel pump, I can just hear some relays under the dash. This didnt happen over a period of time or give me any warning lights. I started the car and drove it in the morning started it up drove home went to use later that day and no start checked the battery and it read 9v. Replaced battery and still no start. Checked the started and its good, when key is turned to start no voltage to the solenoid wire. I'll tell you if I find out whats wrong.
tomyear1,

Is the vehicle cranking at all? This issue may be battery related (e.g. connection issue). This is just a suggestion, not a diagnosis. I encourage you to consult with a certified technician for an official diagnosis. They will be able to offer additional information after inspecting the vehicle.

Please keep us posted. If you have additional questions, please feel free to PM me.

Louis
GM Customer Service
__________________
Check out the NEW Owner Center at: My.Chevrolet.com
Reply With Quote
  #5  
Old 10-09-2012, 01:32 PM
bekurt's Avatar
CF Beginner
 
Join Date: Mar 2012
Posts: 18
Default

It may be your starter.
Reply With Quote
  #6  
Old 10-11-2012, 11:26 AM
CF Beginner
 
Join Date: Oct 2012
Posts: 2
Default

No it wasent cranking, I had it towed to the chevy dealer as it still under warranty. The ECM was hit with a voltage spike, maybe lightning here in Florida. But the dealer was great and replaced it without charge. Now the car starts fine and seems to have more power.
Reply With Quote
  #7  
Old 10-24-2012, 12:30 PM
CF Beginner
 
Join Date: Oct 2012
Posts: 1
Default

It's probably an issue with your battery. When you try to start it, there's no noise at all?
__________________
link in signature removed by moderator
Reply With Quote
Old 10-24-2012, 12:30 PM
 
 
 
Reply

Tags
car, chevy, code, dash, dead, free, fuel, happens, hear, impala, key, lights, passcode, pump, starter, turn


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 10:20 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup