2001 S10 will not go to 4HI 4WD - Chevrolet Forum - Chevy Enthusiasts Forums

2001 S10 will not go to 4HI 4WD


  Reply  
Join Date: Dec 2006
Posts: 2

December 9th, 2006, 6:03 PM   #1  
2001 S10 will not go to 4HI 4WD

I have a 2001 S10 4X4 ext. cab, 114000 miles. A few days ago on snowy pavement in drive stopped at a stop sign, pressed button for 4HI, light flashed and went back to 2HI. Next day, in a snowy parking lot, placed truck in park, pressed 4HI, no response. Same thing if you have it in drive. In neutral, if you press 4HI, light blinks, goes back to 2HI. Press 4LO, both 4HI and 4LO lights blink, goes back to 2HI. I can hear th transfer case motor doing something, not for sure what though. GM dealer told me most common item they have seen replace is the vacum switch, runs about $35. I see where someone with a 2002 S10 Blazer is having the exact same problem I'm having. Can anybody offer up any suggestions? Thanks so much!

 
golfer's Avatar
CF Pro Member

Join Date: Oct 2006
Posts: 611

December 11th, 2006, 2:42 PM   #2  
RE: 2001 S10 will not go to 4HI 4WD

The vacum switch is a common problem.

 
Join Date: Dec 2006
Posts: 3

December 12th, 2006, 9:46 PM   #3  
RE: 2001 S10 will not go to 4HI 4WD

I HAVE A 2003 CHEV S-10 CREW CAB 4X4 AND HAD THE SAME PROBLEM. IN THE PASSENGER SIDE KICK PANEL THERE IS WHAT THEY CALL THETRANSFER CASE CONTROL MODULE . I TOOK THE PANEL OUT AND THE ELECTRICAL THAT GOES IN THE CONTROL MODULE WAS CORODED.I CLEAN OUT THE PINS AND PUT DIELECTRIC GREASE ON THE CONTACTS NOW EVERYTHING WORKS GREAT.HOPE IT MIGHT SOLVE YOUR PROBLEM

 
Join Date: Dec 2006
Posts: 2

December 29th, 2006, 9:23 PM   #4  
RE: 2001 S10 will not go to 4HI 4WD

Gus,

Thanks very much. I did find corrosion in the connectors, both male and female. Used Permatex SA-8 battery cleaner. Foamed up and let it dry. Reconnected and everything is working fine now. Again, thanks much for the advice!

 
dk47's Avatar
CF Beginner

Join Date: Jan 2016
Posts: 1

January 28th, 2016, 3:02 PM   #5  
Cleaning the contact points and applying the grease fixed my 2003 S-10 right up! Thanks!

 
Tags
Search this Thread
Sponsors
Related Topics