4.3 L V6 Rough Idle - Chevrolet Forum - Chevy Enthusiasts Forums

4.3 L V6 Rough Idle


  Reply  
Join Date: Apr 2008
Posts: 1

April 16th, 2008, 10:18 PM   #1  
4.3 L V6 Rough Idle

Hey chevy lovers out there... I am great with SB, but the v6 is new to me...


I have an 89 chevy s-10 Blazer with a 4.3 L. It's got about 106K and runs great. I've had it for about a year, and since I bought it it Idles really rough. Here's the scenario...

-Normal temp
-Timing is dead on per sticker
-When it drives it is smooth as butter, no rough areas while increasing RPM, and no hesitation when accelerating
-All filters have been replaced and it still idles rough with air filter off

I just want to know if this is an indication of pending failure in my motor. It's been this way for over a year and am just wondering if anyone has seen anything like this before. The previous owner told me it was because it was a vortec, but that doesn't sound right to me, it's just too rough. The rough idle is almost rythmical, I am wondering maybee I have a burnt valve or something? ANY HELP IS APPRECIATED!!!!!!

 
Join Date: Dec 2007
Posts: 32

April 17th, 2008, 11:02 PM   #2  
RE: 4.3 L V6 Rough Idle

ORIGINAL: cornwejf

Hey chevy lovers out there... I am great with SB, but the v6 is new to me...


I have an 89 chevy s-10 Blazer with a 4.3 L. It's got about 106K and runs great. I've had it for about a year, and since I bought it it Idles really rough. Here's the scenario...

-Normal temp
-Timing is dead on per sticker
-When it drives it is smooth as butter, no rough areas while increasing RPM, and no hesitation when accelerating
-All filters have been replaced and it still idles rough with air filter off

I just want to know if this is an indication of pending failure in my motor. It's been this way for over a year and am just wondering if anyone has seen anything like this before. The previous owner told me it was because it was a vortec truck part, but that doesn't sound right to me, it's just too rough. The rough idle is almost rythmical, I am wondering maybee I have a burnt valve or something? ANY HELP IS APPRECIATED!!!!!!
Rough idle?? Have you checked your engine support?? Maybe that supprot needs some changing bro

 
Join Date: Dec 2005
Posts: 50

April 24th, 2008, 1:41 AM   #3  
RE: 4.3 L V6 Rough Idle

hi, i will also suggests that you check other car parts like 02 sensors, spark plugs, plug wires, ignition timing, fuel injectors.. also check for some vacuum leaks...

good luck hope this helps..



 
Join Date: Nov 2007
Posts: 38

April 27th, 2008, 8:40 PM   #4  
RE: 4.3 L V6 Rough Idle

Rough idle can be annoying, but when I had a clogged fuel injector it felt like it was missing a spark plug! Maybe just adding some good fuel injector fluid might help, but since you have had this issue a year it sounds more like a mechanical issue, like a vacuum leak or something. If the idle is unbearable, I might be tempted to take it to a shop that can put a machine on it to analyze for causes. Might be something pretty simple. A PCV valve is inexpensive to buy and replace and this you can most likely do yourself before going to a shop. When the little metal ball inside this valve gets gummed up after miles of driving, it interferes with crankcase ventilation. Some of the forum members might support or rule out this fix. It certainly can't hurt to replace the valve as it is a maintenance item anyway. Some folks get away with never replacing this little valve which has been in cars for years.

 
Tags
Search this Thread
Sponsors
Related Topics