91 S10 fuel injection problem? - Chevrolet Forum - Chevy Enthusiasts Forums

91 S10 fuel injection problem?


  Reply  
TheBeastS10's Avatar
Junior Member

Join Date: Apr 2009
Posts: 3

April 18th, 2009, 1:16 PM   #1  
91 S10 fuel injection problem?

i have a 91 s10 blazer and idk wtf the problem is. im gettin fuel all the way to the injectors but not past them. ive replaced fuel pump,fuel filter, am on my 3rd set of injectors,injection unit and im still not getting fuel past the injectors. ive checked all fuses/relays and they are all good? can someone please help me? im about to scrap the whole truck bc i cant figure this out and am spending way to much money

 
mudmaniac's Avatar
Super Moderator
Ride of the Month
May 2009

Join Date: Jan 2008
Posts: 1,637
Westminster, Md.

April 18th, 2009, 8:56 PM   #2  
Have you checked for voltage at the injectors when cranking?

 
TheBeastS10's Avatar
Junior Member

Join Date: Apr 2009
Posts: 3

April 18th, 2009, 9:48 PM   #3  
no i havnt. idk why i didnt think of that. thanks for the idea.

 
TheBeastS10's Avatar
Junior Member

Join Date: Apr 2009
Posts: 3

April 19th, 2009, 8:09 PM   #4  
passenger side reads .04 when cranking and driver side reads .01
idk what this could mean?

 
mudmaniac's Avatar
Super Moderator
Ride of the Month
May 2009

Join Date: Jan 2008
Posts: 1,637
Westminster, Md.

May 9th, 2009, 4:45 AM   #5  
Posted By: TheBeastS10 passenger side reads .04 when cranking and driver side reads .01
idk what this could mean?
I think it means that it's time to replace the ECM or the computer.
You could match up a used one.

 
mikeross's Avatar
CF Beginner

Join Date: Sep 2009
Posts: 27

October 16th, 2009, 2:11 AM   #6  
I had that same problem before so I ended up replacing the fuel pump and injectors. Then still nothing happened. I checked the voltage and i'l try to replace the ECM. Where is it located on the 92 blazer? Thanks


Last edited by mikeross; October 19th, 2009 at 9:21 PM.
 
mudmaniac's Avatar
Super Moderator
Ride of the Month
May 2009

Join Date: Jan 2008
Posts: 1,637
Westminster, Md.

October 16th, 2009, 5:35 AM   #7  
It should be under the dash, behind the glove box.

 
Tags
Search this Thread
Sponsors
Related Topics