Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Past Chevy Truck, SUV & Vans > S-10 & Blazer
Sign in using an external account
Register Forgot Password?
Search

S-10 & Blazer 1982-2005
The S-10 and Blazer was arguably the most versatile and accessorizable mid-size truck and SUV on the market.
Platform: S/T-series & GMT 330

Reply
 
 
 
 
LinkBack Thread Tools
  #1  
Old 03-14-2010, 03:00 PM
CF Beginner
1991 Chevrolet S-10
 
Join Date: Mar 2010
Location: johnson city, TN
Posts: 3
Default cant get my 91 s10 to start

about 3 months ago my s10 stopped running. it will turn over but wont start. i can start it by pouring gas in the throttle body but other than that nothing ive tried works. ive replaced the fuel pump,strainer,filter,fuel pump relay,fuel pressure regulator, igition module,ignition switch,idle air module and the computer. i when the switch is on the relay dont kick on and cant figure out why. but when i bypass the relay i still dont get any gas through the injectors. can some 1 help me out? or what else it could be? thanks
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 03-14-2010, 05:11 PM
maxxman04's Avatar
CF Veteran
1990 Chevrolet Camaro
 
Join Date: Dec 2009
Location: kentucky
Posts: 1,854
http://www.facebook.com/home.php?ref=hp
Default

check all the fuses. then look for bad connection to the relay. put power to the wire that feeds the actual fuel pump and see if the pump will kick on. this can help narrow it down
__________________
rednekper4mince. keepin duct tape and bailing wire in business.
Reply With Quote
  #3  
Old 03-14-2010, 05:46 PM
CF Beginner
1991 Chevrolet S-10
 
Join Date: Mar 2010
Location: johnson city, TN
Posts: 3
Default

all fuses are good, checked all conections they are good, pump will come on if power is applied to the pump
Reply With Quote
  #4  
Old 03-15-2010, 02:30 PM
CF Beginner
 
Join Date: Mar 2010
Location: Cunningham, TN
Posts: 28
Send a message via MSN to Rogers mechanical repair service Send a message via Yahoo to Rogers mechanical repair service
Default

So let me get this strait. You energize the fuel pump and it still doesn't get fuel to the injectors or is it the injectors are not spraying. Take the fuel line off at the intake to see if you have fuel getting to the injectors. My 87 had a blown rubber hose on the fuel pump assymbly. Inwhich Litle to no fuel would flow through the lines.
Reply With Quote
  #5  
Old 03-28-2010, 07:23 AM
CF Beginner
1991 Chevrolet S-10
 
Join Date: Mar 2010
Location: johnson city, TN
Posts: 3
Default

thanks to all that has replied got it running. it was a short n a power wire that went to the main computer.

but still have an issue with the check engine light flashes rapidly all the time the truck is running. any clues?
Reply With Quote
  #6  
Old 04-08-2010, 02:42 PM
CF Junior Member
 
Join Date: Feb 2010
Posts: 62
Default

just reset the codes and see if it still does it and if it is still doing that then check all your connections fot the regulator pump and lines for everything.
Reply With Quote
Old 04-08-2010, 02:42 PM
 
 
 
Reply

Tags
1991, 91, 91s10, arent, chevy, ecm, fuel, injectors, pressure, rebuild, regulator, reset, s10, spraying, squirting


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Join Chevroletforum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 02:45 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup