2008 Silverado cruise control is not working - Chevrolet Forum - Chevy Enthusiasts Forums

2008 Silverado cruise control is not working


  Reply  
crwalker2's Avatar
CF Beginner

Join Date: May 2010
Posts: 16

July 16th, 2010, 11:49 AM   #1  
2008 Silverado cruise control is not working

I have a 2008 Silverado LT, 2WD, 5.3L. Over the past few months my cruise control has worked and not worked for no apparent reason. Some days I would get in it to go to work and the cruise would work normally and if I had to hit the brakes for any reason it may or may not come back on at all. Now we're to the point where it doesn't work at all anymore. The on/off switch still lights up and I have checked all the fuses. I have no idea where to begin.
Any help would be greatly appreciated.

 
dungholio's Avatar
CF Beginner

Join Date: Jul 2010
Posts: 11

July 17th, 2010, 7:18 PM   #2  
it could be the "set" switch. when you try and set the cruise speed, try pushing the set button in different areas of the switch, if it comes on then possibly it needs a new cruise switch assy.... let me know what you figure out

 
crwalker2's Avatar
CF Beginner

Join Date: May 2010
Posts: 16

July 19th, 2010, 12:43 AM   #3  
I tried what you suggested and didn't get any results. I don't know much of anything about cruise control, especially the "drive by wire" systems. I have had the throttle body replaced twice because the first two about blew up the motor (would make the motor accelerate to about 4000 rpm and climbing before I would shut it off, while it was in park), when I asked the dealer they told me the throttle body had nothing to do with the cruise control and it could be a 100 different things that could cause it not to work. They said it wouldn't give a code for the cruise control. I have checked all the connectors and fuses and don't see anything obvious.
If you have anymore suggestions, I would love to hear!
Thank you for your reply.

 
in2pro's Avatar
Administrator

Join Date: Apr 2008
Posts: 7,253
Austin, Texas

July 19th, 2010, 6:34 AM   #4  
A 2008, do you still have any warranty left?

 
in2pro's Avatar
Administrator

Join Date: Apr 2008
Posts: 7,253
Austin, Texas

July 19th, 2010, 6:40 AM   #5  
Posted By: crwalker2 if I had to hit the brakes for any reason it may or may not come back on at all. Now we're to the point where it doesn't work at all anymore. The on/off switch still lights up and I have checked all the fuses. I have no idea where to begin.
Any help would be greatly appreciated.
I think all new body style vehicles the cruise is controlled by the BCM, however you could check to make sure there is not a switch on the brake peddle that is stuck or not operating. The cruise will not activate if it thinks the brakes are being applied...

 
Chevrolet Customer Service's Avatar
Official GM Rep

Join Date: Mar 2010
Posts: 4,089
Global Headquarters in Detroit, MI

July 19th, 2010, 7:45 PM   #6  
crwalker2, I would like to direct message you about this issue. Thank you for your time.

Jeff Morris, Chevrolet Customer Service

 
crwalker2's Avatar
CF Beginner

Join Date: May 2010
Posts: 16

July 19th, 2010, 10:08 PM   #7  
No I don't have any warranty left. I use this truck for my business so it has a lot of miles on it, over 113,000 on it now. I have had very few issues, it has been an great truck so I'm not complaining just looking for some help.

 
crwalker2's Avatar
CF Beginner

Join Date: May 2010
Posts: 16

July 19th, 2010, 10:11 PM   #8  
The truck does have switch on the pedal. The brake lights themselves don't stay on all the time. Do you know if it is seperate or the lights? Or maybe something to do with the indicator for the trailer brakes?

 
coogdad's Avatar
CF Beginner

Join Date: Nov 2010
Posts: 6

November 15th, 2010, 3:18 PM   #9  
My 2008 Silverado Z71 4x4 is doing the same thing. The cruise control became intermittent, worked sometimes and sometimes it did not. Now it does not work at all. The on/off light on the steering works, but I cannot activate the cruise control with the set button. Going to check this brake switch near the peddle tonite to see if there is anything there.

Any other suggestions on this issue? Seems like a common problem. I have also had two of my power door locks malfunction. Both front and rear on passenger side.

 
SleepingGiant's Avatar
CF Beginner

Join Date: Nov 2010
Posts: 18
SoCal

November 15th, 2010, 5:05 PM   #10  
I had the same problem with my cruise control not working after i installed high intensity bulbs in my headlights. What happened was the lights drew more power and heated up and melted. These wires are all bundled up together behind the dash. I took it to the dealer becuase my fog lights wouldnt work. So they took apart the dash and yes all the wires were fried. They respliced a few of the damaged ones and wa-la everything worked. The cruise was back on and my fogs worked. So you may have a short somewhere.

 
Tags
Search this Thread
Sponsors
Related Topics