2010 Silverado stabiliTrak question - Chevrolet Forum - Chevy Enthusiasts Forums

2010 Silverado stabiliTrak question


  Reply  
Rev500ss's Avatar
CF Beginner

Join Date: Jan 2012
Posts: 12

January 4th, 2012, 6:57 PM   #1  
2010 Silverado stabiliTrak question

Hi there, I am in here, and have a question

I bought a 2010 Silverado LT in June and have now been getting the stabiliTrak light coming on now and then. One day its off the next day it comes on, then it might be off for a week, then start coming on again.

Is there anyway to check or reset this system?
Why would this light be coming on?

Any help would be great

Thanks in advance

Rev500ss

 
Chevrolet Customer Service's Avatar
Official GM Rep

Join Date: Mar 2010
Posts: 4,106
Global Headquarters in Detroit, MI

January 4th, 2012, 10:15 PM   #2  
<!--[if gte mso 9]><xml> <w:WordDocument> <w:View>Normal</w:View> <w:Zoom>0</w:Zoom> <w:PunctuationKerning/> <w:ValidateAgainstSchemas/> <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid> <w:IgnoreMixedContent>false</w:IgnoreMixedContent> <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText> <w:Compatibility> <w:BreakWrappedTables/> <w:SnapToGridInCell/> <w:WrapTextWithPunct/> <w:UseAsianBreakRules/> <wontGrowAutofit/> </w:Compatibility> <w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel> </w:WordDocument> </xml><![endif]--><!--[if gte mso 9]><xml> <w:LatentStyles DefLockedState="false" LatentStyleCount="156"> </w:LatentStyles> </xml><![endif]--><!--[if gte mso 10]> <style> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} </style> <![endif]--> Rev500ss,

StabiliTrak is an advanced computer controlled system that assists the driver with directional control of the vehicle in difficult driving conditions.

StabiliTrak activates when the computer senses a discrepancy between the intended path and the direction the vehicle is actually traveling. StabiliTrak selectively applies braking pressure at any one of the vehicle's brakes to assist the driver with keeping the vehicle on the intended path.

When the vehicle is started and begins to move, the system performs several diagnostic checks to insure there are no problems. The system may be heard or felt while it is working. This is normal and does not mean there is a problem with the vehicle. The system should initialize before the vehicle reaches 20 mph (32 km/h). In some cases, it may take approximately two miles of driving before the system initializes.

If cruise control is being used when StabiliTrak activates, the cruise control automatically disengages. The cruise control can be re-engaged when road conditions allow.

If the system fails to turn on or activate, the StabiliTrak light along with one of the following messages will be displayed on the Driver Information Center (DIC): TRACTION CONTROL OFF, SERVICE TRACTION CONTROL, STABILITRAK OFF, SERVICE STABILITRAK. If these DIC messages appear, make sure the StabiliTrak system has not been turned off using the StabiliTrak on/off button. Then turn the steering wheel clockwise from the nine o'clock position to the three o'clock position. If this clears the message(s), the vehicle does not need servicing. If this does not clear the message(s), then turn the vehicle off, wait 15 seconds, and then turn it back on again to reset the system. If any of these messages still appear on the DIC, the vehicle should be taken in for service.

The StabiliTrak light will flash on the instrument panel cluster when the system is both on and activated.

I hope this information is helpful!

If you have any additional questions, please feel free to contact me.

Louis
GM Customer Service

 
Rev500ss's Avatar
CF Beginner

Join Date: Jan 2012
Posts: 12

January 6th, 2012, 2:15 PM   #3  
Thanks for your reply, that looks like it came straight from my manual. either way I will try to reset the system next time if and when it happens.

Thanks for your help

Rev500ss

 
ablue79's Avatar
CF Beginner

Join Date: Mar 2013
Posts: 2

March 11th, 2013, 12:40 PM   #4  
stabilitrak

Hello Louis, I too have been experiencing intermittent messages with 2010 Silverado 4x4 DIC. No rhyme or reason but becoming more frequent. After reading your post I tried the suggestions. Messages rotate from "service", to "traction off" etc. No change in performance. Turning the wheel from 3 to 9has no effect. It does reset after shut down. I observed however, that sitting still, in Park, after a reset, all I have to do is slightly turn the steering wheel and it triggers the sequence again. Could this be a front wheel sensor issue? Thanks, Greg

 
f5fstop's Avatar
CF Junior Member

Join Date: Mar 2013
Posts: 80

March 11th, 2013, 5:48 PM   #5  
Is the service engine soon light coming on? A bad wheel sensor, "should" set a code (C00**).
And it could even be just a bad idiot light in the cluster.

 
Chevrolet Customer Service's Avatar
Official GM Rep

Join Date: Mar 2010
Posts: 4,106
Global Headquarters in Detroit, MI

March 11th, 2013, 8:19 PM   #6  
Posted By: ablue79 Hello Louis, I too have been experiencing intermittent messages with 2010 Silverado 4x4 DIC. No rhyme or reason but becoming more frequent. After reading your post I tried the suggestions. Messages rotate from "service", to "traction off" etc. No change in performance. Turning the wheel from 3 to 9has no effect. It does reset after shut down. I observed however, that sitting still, in Park, after a reset, all I have to do is slightly turn the steering wheel and it triggers the sequence again. Could this be a front wheel sensor issue? Thanks, Greg
<!--[if gte mso 9]><xml> <w:WordDocument> <w:View>Normal</w:View> <w:Zoom>0</w:Zoom> <w:PunctuationKerning/> <w:ValidateAgainstSchemas/> <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid> <w:IgnoreMixedContent>false</w:IgnoreMixedContent> <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText> <w:Compatibility> <w:BreakWrappedTables/> <w:SnapToGridInCell/> <w:WrapTextWithPunct/> <w:UseAsianBreakRules/> <wontGrowAutofit/> </w:Compatibility> <w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel> </w:WordDocument> </xml><![endif]--><!--[if gte mso 9]><xml> <w:LatentStyles DefLockedState="false" LatentStyleCount="156"> </w:LatentStyles> </xml><![endif]--><!--[if gte mso 10]> <style> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} </style> <![endif]--> ablue79,

Iím sorry you are experiencing this issue. I recommend consulting with a certified technician for additional assistance. They will be able to provide more information after physically inspecting the vehicle.

If you need assistance locating a technician near you, please PM me your zip code.

Louis
GM Customer Service

 
ablue79's Avatar
CF Beginner

Join Date: Mar 2013
Posts: 2

March 12th, 2013, 10:12 AM   #7  
Thanks for the response. No "service engine" light. I suppose I will go to dealer for a code check. Our local dealer wanted $100 to run diag. on it. We have another dealer 30 min. away. I will try them. Truck has 70,000. Should be a warranty issue. Correct? Thanks, Greg

 
nukstr's Avatar
CF Beginner

Join Date: Dec 2013
Posts: 8

December 20th, 2013, 12:00 AM   #8  
FINALLY FIXED, "SERVICE STABILITRAK & TRACTION CONTROL DIAGNOSTIC PROBLEM:
"SERVICE STABILITRAK",
"SERVICE TRACTION CONTROL",
"HARD SHIFT 1-2 GEARS"-(STABILITRAK TURNING OFF-CLUNK NOISE)
"STABILITRAK OFF",
"TRACTION CONTROL OFF"
----------------------------------------------------------------------------------
CAUSE:
FUEL WAS 45% ETHANOL @ 85-(COSTCO GAS)-COMPUTER WENT INTO LIMP MODE CAUSING (AFM) TO GET STUCK AND NOT RESET COMPUTER.
----------------------------------------------------------------------------------
SOLUTION:
DRAINED & CLEANED GAS TANK-
CHANGED FUEL FILTERS (*ONLY IF NEEDED)
CLEANED INJECTORS-
RESET COMPUTER-
FILLED GAS TANK WITH NO ETHANOL- (Ethanol-free gas stations in the U.S. and Canada)
TOTAL AMOUNT WITH TAX: $444.86
----------------------------------------------------------------------------------
REFERENCES
(STABILITRAK CLUNK NOISE): 2010 Silverado stabiliTrak question
(AFM)-Definition: Active Fuel Management - Wikipedia, the free encyclopedia
(ETHANOL): Common ethanol fuel mixtures - Wikipedia, the free encyclopedia
(GAS STATIONS WITHOUT ETHANOL): Ethanol-free gas stations in the U.S. and Canada

 
Jacob Cozy's Avatar
CF Beginner

Join Date: Jul 2016
Posts: 1

July 5th, 2016, 4:42 PM   #9  
I am having the same problem with my tahoe. it says service stabletrack, tractions control, brakes, & tire monitoring system. do you know a technician near 80206 Denver?

 
Tags
Search this Thread
Sponsors
Related Topics