88 chevy auto transmission problem - Chevrolet Forum - Chevy Enthusiasts Forums

88 chevy auto transmission problem


  Reply  
clehman's Avatar
Junior Member

Join Date: May 2009
Posts: 1

May 2nd, 2009, 8:16 PM   #1  
88 chevy auto transmission problem

I have a 88 1500 silverado 350 with auto transmission. I was doing some off roading the other night and got into some mushy ground. I did do some fairly rapid shifting from reverse to drive to rock my way back out of the mud. I drove truck home in drive. When I got in it the next day and put truck into overdrive it won't shift any different than it does in drive. Almost like there is no fourth now. Any ideas on what may have caused me to lose 4th?

 
Mike Sigmond's Avatar
Super Moderator
ROTM Coordinator

Join Date: Apr 2009
Posts: 1,947
Orange County, CA

May 3rd, 2009, 12:00 AM   #2  
Welcome aboard CF!

How deep in the mud did you get , did the frame bottom out and get mud up in the drivetrain? Could be electrical or damage in my opinion. Hopefully someone here can help you better with your drivetrain specifics & diagnostics.

Good Luck!

 
therewolf's Avatar
Super Moderator

Join Date: May 2008
Posts: 2,395

May 3rd, 2009, 5:32 AM   #3  
Forum search "4L60E transmission", there's 3 or four posts on this site about this specific problem.

 
mudmaniac's Avatar
Super Moderator
Ride of the Month
May 2009

Join Date: Jan 2008
Posts: 1,637
Westminster, Md.

May 3rd, 2009, 6:27 AM   #4  
I don't think you would have the 4L60E in that year but I may be wrong, before you get too involved with it crawl underneath and see if you tore any wiring off or bent the shifter linkage.

 
Tags
Search this Thread
Sponsors
Related Topics