95 GMC misses/runs rough after warmup - Chevrolet Forum - Chevy Enthusiasts Forums

95 GMC misses/runs rough after warmup


  Reply  
Join Date: Oct 2006
Posts: 77

October 17th, 2006, 12:22 PM   #1  
95 GMC misses/runs rough after warmup

Hey people
I have a 95 GMC c1500 pickup w/5.7 & auto. The problum is as follows. When staring with a cold engine it runs fine but, as soon as the engine warms up to operating temp (only a couple of minits) it will hesitate/stumble around 1200 to 1800 RPM yet it will idle just fine. It does not matter weather it is under a load or not. Check engine light is not on & has no codes present. It was doing this when I bought it with 161000 miles. have replaced the following mostly because it really needed it; cap, rotor, coil, plugs, plug wires, map sensor, tps, fuel filter. Also have checked the engine gound wires & checked for vacuum leaks. Since it runs smooth at idle I don't beleive it has vacuum leaks. The spary pattern for the injectors seems to be fine. I have not checked fuel pressure but since it accelerates fine under full thottle I did'nt think theres a problum with the pump. Is anyone here familar with these symptoms? Are there common issuses with the base plates wearing out on the throttle body? Or do the distributor bushings wear out? Im stumped!!!

 
Join Date: Jun 2006
Posts: 75

October 17th, 2006, 8:45 PM   #2  
RE: 95 GMC runs rough after warmup

check the EGR valve, sounds stuck open to me but I could be wrong.

 
Join Date: Oct 2006
Posts: 24

October 18th, 2006, 2:27 AM   #3  
RE: 95 GMC runs rough after warmup

I have a 99 with the same set up. I do have a Service Engine Soon light on. Mine is making the same problem. Autozone checked it and said I need a new catalytic converter.

 
Join Date: Oct 2006
Posts: 77

October 18th, 2006, 3:33 PM   #4  
RE: 95 GMC runs rough after warmup

thanks for your responce guys, to Carpenterbill---- I have been courious about the EGR system, I can move the EGR diapharm with my finger but I know it is not a good test. to 99silverado----- since my truck accelerates fine under full power logic tells me the cat converter is not blocked , and as for the guys at AutoZone----- are you really going to trust what they say????? All they are good for is giving codes.

 
Join Date: Oct 2006
Posts: 77

October 20th, 2006, 10:13 PM   #5  
RE: 95 GMC runs rough after warmup

anyone else ??????

 
Join Date: Oct 2006
Posts: 77

November 6th, 2006, 5:28 PM   #6  
RE: 95 GMC runs rough after warmup

try again

 
Join Date: Mar 2008
Posts: 1

March 16th, 2008, 6:01 PM   #7  
RE: 95 GMC runs rough after warmup

my truck is doing the exact same thing. 95 gmc yukon. any suggestions?

 
northey87's Avatar
Super Moderator

Join Date: Oct 2007
Posts: 1,274
Dayton PA

March 16th, 2008, 10:42 PM   #8  
RE: 95 GMC runs rough after warmup

95gmcyukon, welcome to the forum!!!

Have the injectors been checked or serviced lately?

 
Join Date: Feb 2008
Posts: 158

March 18th, 2008, 7:44 AM   #9  
RE: 95 GMC runs rough after warmup

Your coil is bad. Replace the ignition coil, it's cheap too, probally $30.

 
Join Date: Oct 2006
Posts: 77

March 18th, 2008, 11:13 AM   #10  
RE: 95 GMC runs rough after warmup

no the coils is not bad. I have replaced it already!

 
Search this Thread
Sponsors
Related Topics