Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevy Trucks, SUV's, Crossovers & Vans > Silverado & Fullsize Pick-ups
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Search Today's Posts Mark Forums Read GarageUsed CarsVendors TSB & Recalls
Search
Welcome to Chevrolet Forum - Chevy Enthusiasts Forums

Silverado & Fullsize Pick-ups The Silverado has been one of the best selling trucks in the US for decades, and is truly proven to be "like a rock".

2014 Chevy Silverado
Platform: Truck, GMT 400, 800, & 900
Sponsored by: Bakliner

Reply
 
 
 
 
LinkBack Thread Tools
  #1  
Old 10-17-2006, 11:22 AM
 
Join Date: Oct 2006
Posts: 77
Default 95 GMC misses/runs rough after warmup

Hey people
I have a 95 GMC c1500 pickup w/5.7 & auto. The problum is as follows. When staring with a cold engine it runs fine but, as soon as the engine warms up to operating temp (only a couple of minits) it will hesitate/stumble around 1200 to 1800 RPM yet it will idle just fine. It does not matter weather it is under a load or not. Check engine light is not on & has no codes present. It was doing this when I bought it with 161000 miles. have replaced the following mostly because it really needed it; cap, rotor, coil, plugs, plug wires, map sensor, tps, fuel filter. Also have checked the engine gound wires & checked for vacuum leaks. Since it runs smooth at idle I don't beleive it has vacuum leaks. The spary pattern for the injectors seems to be fine. I have not checked fuel pressure but since it accelerates fine under full thottle I did'nt think theres a problum with the pump. Is anyone here familar with these symptoms? Are there common issuses with the base plates wearing out on the throttle body? Or do the distributor bushings wear out? Im stumped!!!
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 10-17-2006, 07:45 PM
 
Join Date: Jun 2006
Posts: 75
Default RE: 95 GMC runs rough after warmup

check the EGR valve, sounds stuck open to me but I could be wrong.
Reply With Quote
  #3  
Old 10-18-2006, 01:27 AM
 
Join Date: Oct 2006
Location:
Posts: 24
Default RE: 95 GMC runs rough after warmup

I have a 99 with the same set up. I do have a Service Engine Soon light on. Mine is making the same problem. Autozone checked it and said I need a new catalytic converter.
__________________
GNinTN
Reply With Quote
  #4  
Old 10-18-2006, 02:33 PM
 
Join Date: Oct 2006
Posts: 77
Default RE: 95 GMC runs rough after warmup

thanks for your responce guys, to Carpenterbill---- I have been courious about the EGR system, I can move the EGR diapharm with my finger but I know it is not a good test. to 99silverado----- since my truck accelerates fine under full power logic tells me the cat converter is not blocked , and as for the guys at AutoZone----- are you really going to trust what they say????? All they are good for is giving codes.
Reply With Quote
  #5  
Old 10-20-2006, 09:13 PM
 
Join Date: Oct 2006
Posts: 77
Default RE: 95 GMC runs rough after warmup

anyone else ??????
Reply With Quote
  #6  
Old 11-06-2006, 04:28 PM
 
Join Date: Oct 2006
Posts: 77
Default RE: 95 GMC runs rough after warmup

try again
Reply With Quote
  #7  
Old 03-16-2008, 05:01 PM
 
Join Date: Mar 2008
Posts: 1
Default RE: 95 GMC runs rough after warmup

my truck is doing the exact same thing. 95 gmc yukon. any suggestions?
Reply With Quote
  #8  
Old 03-16-2008, 09:42 PM
northey87's Avatar
Super Moderator
 
Join Date: Oct 2007
Location: Dayton PA
Posts: 1,274
Default RE: 95 GMC runs rough after warmup

95gmcyukon, welcome to the forum!!!

Have the injectors been checked or serviced lately?
__________________
'95 1500 Silverado, 350, flowmaster Force II exhuast, S&B CAI.

Reply With Quote
  #9  
Old 03-18-2008, 06:44 AM
 
Join Date: Feb 2008
Location:
Posts: 158
Default RE: 95 GMC runs rough after warmup

Your coil is bad. Replace the ignition coil, it's cheap too, probally $30.
__________________
1994 K2500 454 4L80E 14bolt 10.5" w/ 4.10's
Reply With Quote
  #10  
Old 03-18-2008, 10:13 AM
 
Join Date: Oct 2006
Posts: 77
Default RE: 95 GMC runs rough after warmup

no the coils is not bad. I have replaced it already!
Reply With Quote
Old 03-18-2008, 10:13 AM
 
 
 
Reply

Tags
454, 4x4, 95, accelerating, astro, blazer, chevy, gmc, misses, rough, running, runs, sensor, temp, warm


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 01:39 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup