97 1500 wont fire - Chevrolet Forum - Chevy Enthusiasts Forums

97 1500 wont fire


  Reply  
  #1  
Old  January 28th, 2012, 7:04 AM
  • CF Beginner
    Join Date: Jan 2012
    Posts: 3
97 1500 wont fire

I got a friend with a 97 1500 4x4 5.0l and the truck died on him yesterday. His wife said it started up then ran for a couple seconds then died, I went to look at it for him, first thing I checked was spÓrk, which it had, but a orangeish color. Then I checked fuses for fuel pump they are good so is the relay, then me and my dad went their quick to look at it, he sprayed some start I fluid in it and it fired then i heard a loud knocking when it ran for those few seconds, then it backfired then started on fire, we tried to suck the flame back in but it wouldn't go out, so we think the timing may have jumped. The truck has 190k.
Can the timing jump on these motors?
I did use my tire pressure guage on the fuel rail and gas came out, now the only thing I'm worried about is if the timing jumped did i f'up the valves. ╬ going to check the. Timing today but I don't see the marks on the dampener pulley, so i got to pull #1 and do tdc and check thŔ rotor.
Could their be a sensor that is bad and causing the truck not to run also?

  #2  
Old  January 28th, 2012, 7:40 AM
  • CF Senior Member
    Join Date: Feb 2011
    Posts: 345
    Middletown DE
how many miles,i had problems with the crank sensor that would cause the engine stop when the starter was trying to turn it over destroyed a starter and flex plate

Engine - No/Hard/Slow Start/Backfire/Kickback

File In Section: 06 - Engine/Propulsion System

Bulletin No.: 00-06-04-014

Date: April, 2000

TECHNICAL

Subject:
No, Hard, or Slow Start, Backfire or "Kickback" During
Crank/Start, "Grinding" or Unusual Noises During Crank, DTC P0338
(Replace Crankshaft Position Sensor)

Models:
1999-2000 Cadillac Escalade
1995-2000 Chevrolet and GMC SIT Models
1996-2000 Chevrolet and GMC C/K, M/L, G, P Models
1996-2000 Oldsmobile Bravada
with 4.3 L, 5.0 L, 5.7 L or 7.4 L Engine
(VINs W, X, M, R, J RPOs L35, LF6, L30, L31, L29)

Condition:
Some customers may comment on one or more of the following conditions:

^ Backfire during crank/start
^ "Kickback" during crank/start
^ "No" start
^ "Slow" or "hard" start/crank
^ "Grinding" or unusual noises during crank/start
^ Cracked or broken engine block at the starter boss
^ Broken starter drive housing
^ Broken starter ring gear on flywheel
^ Any combination of the above

Cause:
A condition may exist that allows the crankshaft position sensor to command up to 50 extra degrees of spark advance during engine cranking only. This in turn exposes the engine to higher than normal cylinder pressures which may result in an inoperative condition to the starter drive housing, the engine flywheel starter ring gear, or the engine block at the outside edge of the starter boss.

Correction:
Inspect for a stored powertrain DTC code P0338. This DTC will NOT illuminate the "Service Engine Soon" light. If this code is stored, the Crankshaft Position Sensor, P/N 10456607, MUST be replaced and the remaining components inspected for damage (engine block at the starter boss, the starter drive housing, and the engine flywheel starter ring gear).

Notice : When DTC code P0338 is set, failure to replace the Crankshaft Position Sensor could result in repeated inoperative conditions of the starter or flywheel.

Important : Some flywheel wear is normal; broken or missing teeth and/or cracks, are not normal.

Parts Information

Parts are currently available from GMSPO.

Warranty Information:


  #3  
Old  January 28th, 2012, 11:17 AM
  • CF Beginner
    Join Date: Jan 2012
    Posts: 3
190k on it, I did find a way to test the crank position sensor and I tested it, 12v of power but I don't seem to get any reading on the feedback wire

  #4  
Old  January 30th, 2012, 3:25 PM
  • CF Beginner
    Join Date: Jan 2012
    Posts: 3
Well it turned out to be the fuel pump.


  Reply
Tags
Search this Thread
Sponsors