Aftermarket Radio Install - Issues 2006 Silverado - Chevrolet Forum - Chevy Enthusiasts Forums

Aftermarket Radio Install - Issues 2006 Silverado


  Reply  
  #1  
Old  February 24th, 2012, 8:32 PM
  • CF Beginner
    Join Date: Feb 2012
    Posts: 3
Aftermarket Radio Install - Issues 2006 Silverado

I purchased a 2006 silverado with the work truck package last week and tried to install a aftermarket radio in it tonight. I have absolutely hit a wall trying to get this installed as there some issue with the harness that does not allow for switched wiring from the factory deck. So I tried to attach a fuse tap into the 10a SEO Accesory however I have cd power (hear noise as it is conncected) but no lights. What have I done? Do I need higher amperage?

  #2  
Old  February 24th, 2012, 8:55 PM
  • CF Active Member
    Join Date: Nov 2011
    Posts: 177
    Idaho
Wait you cant disconect the harnes to put the after market harnes in?

  #3  
Old  February 24th, 2012, 9:28 PM
Don't know which one you have for sure but you will probably be needing one of these.

Metra Online

  #4  
Old  February 25th, 2012, 9:25 AM
  • CF Beginner
    Join Date: Feb 2012
    Posts: 3
I purchased a Sony deck and it came with a harness in the box. I cut the old harness off of the factory deck and just started connecting wires to each other with wire nuts. All wires matched except the truck does not have a switched power wire.

  #5  
Old  February 25th, 2012, 1:37 PM
  • CF Beginner
    Join Date: Feb 2012
    Posts: 3
I figured it out. My mistake was that I had wired the antenna wire to the data line (small orange). Everything is working now. Thanks for the help.


  Reply
Tags
Search this Thread
Sponsors