cruise control not working - Chevrolet Forum - Chevy Enthusiasts Forums

cruise control not working


  Reply  
john preuit's Avatar
CF Beginner

Join Date: Jul 2010
Posts: 1

July 15th, 2010, 10:36 AM   #1  
cruise control not working

i drove my 03' chevy silverado z-71 about 5 miles down a muddy road 3 weeks ago adn now the cruise control will not work at all. every thing as far as lights on the truck still works but no cruise control. fuse are still good in the dash panel. needing help to get this figured out due to the 5 hour commute each way to work every week from home, active duty navy.

 
in2pro's Avatar
Administrator

Join Date: Apr 2008
Posts: 7,254
Austin, Texas

July 15th, 2010, 1:25 PM   #2  
Welcome to the fourm

 
in2pro's Avatar
Administrator

Join Date: Apr 2008
Posts: 7,254
Austin, Texas

July 15th, 2010, 1:41 PM   #3  
I am not certain for the 03 models but for my 07 Tahoe the cruise control I believe is managed by the BCM (Body Control Module)
You may want to try resetting the system by disconnecting the battery for several minutes...

 
Cpb200's Avatar
CF Active Member

Join Date: Jul 2010
Posts: 172

July 15th, 2010, 4:05 PM   #4  
im having the same problem with my 99 everything works light, fuses are good
but it just doesnt hold the speed i went ahead and went to a junk yard and pulled the brains of the cruise control(sorry i forgot the name) and changed it out on my truck but still nothing
im goin to try to pull another one and see what it does

 
Tags
Search this Thread
Sponsors
Related Topics