Neutral Safety Switch? - Chevrolet Forum - Chevy Enthusiasts Forums

Neutral Safety Switch?


  Reply  
mdl2424's Avatar
CF Beginner

Join Date: Dec 2010
Posts: 2

December 21st, 2010, 6:53 PM   #1  
Neutral Safety Switch?

I have a 1995 k1500, 5.7l, auto trans. My intermittent problem is now constant. When I turn the key everything powers up but no cranking and no clicking. Starter was replaced. I can jump across the starter and it starts fine. Thoughts? Neutral Safety Switch? How would I test it?
THANKS!

 
stevegr8's Avatar
CF Beginner

Join Date: Dec 2010
Posts: 5

December 21st, 2010, 11:20 PM   #2  
after many tries i didnt find out the solution

 
OLD WRENCH's Avatar
CF Senior Member

Join Date: Nov 2010
Posts: 368

December 22nd, 2010, 8:42 PM   #3  
If you are trying to start in Park,try neutral, sometimes this will work on a bad switch. Next would be to jump the switch,for which you will need a wiring diagram or maybe someone can chime in that knows the wire colors. Does your key have a chip in it? I fixed the wifes Buick that was acting this way by scrubbing the key with dish soap and a brush.

 
mdl2424's Avatar
CF Beginner

Join Date: Dec 2010
Posts: 2

December 23rd, 2010, 5:26 PM   #4  
Neutral Safety Switch

I have tried starting it in nuetral with no luck. The key does not have a chip in it.

The crazy thing is, shortly after posting my question, the darn thing started right up with the key, and has not missed a beat for two days now. IT IS DRIVING ME CRAZY!

Thanks for the ideas. I can probably find a wiring diagram if / when it happens again. Do you know where the wires go to that I should be jumping?

 
silverado13's Avatar
CF Active Member

Join Date: Sep 2010
Posts: 264
Baton Rouge LA

December 29th, 2010, 12:34 PM   #5  
i just solved that exact problem i was having with mine, if you go under the hood in the fuse box, the ENG 1 fuse should be blown, try replacing the fuse, it will let you start it, put it in drive and then back in park, shut it off and try to turn it back on, if the fuse is blown again, then its you MLPS (manual lever position switch) aka you neutral safety switch, when the fuse is blown, the park indicator in your cluster shouldnt light up, the neutral safety switch is bolted to the drivers side of your transmission, its like a 14 or 15mm nut to get the linkage off and 2 13mm bolt to get the switch off, ive seen them new for $45 but i went to the junkyard to get mine

 
silverado13's Avatar
CF Active Member

Join Date: Sep 2010
Posts: 264
Baton Rouge LA

December 29th, 2010, 12:37 PM   #6  
Posted By: OLD WRENCH If you are trying to start in Park,try neutral, sometimes this will work on a bad switch. Next would be to jump the switch,for which you will need a wiring diagram or maybe someone can chime in that knows the wire colors. Does your key have a chip in it? I fixed the wifes Buick that was acting this way by scrubbing the key with dish soap and a brush.
yeah i had to rewire mine because the connectors were stuck in the switch and its a pain, i literally had to cut a wire, soder it and then move to the next, the reason why is because there are 2 green, 2 purple, 3 yellow, 2 pink and 2 black, 11 wires total, and none of them have strips or anything to set them apart from the other same color


Last edited by silverado13; December 29th, 2010 at 12:41 PM.
 
340,000chevytruck's Avatar
CF Beginner

Join Date: Jun 2013
Posts: 1

June 12th, 2013, 5:24 PM   #7  
Posted By: silverado13 yeah i had to rewire mine because the connectors were stuck in the switch and its a pain, i literally had to cut a wire, soder it and then move to the next, the reason why is because there are 2 green, 2 purple, 3 yellow, 2 pink and 2 black, 11 wires total, and none of them have strips or anything to set them apart from the other same color
That works if ur buddy just didnt cut all the wires. How do you tell them apart if they were just cut and left to dangle?

 
618 gearhead's Avatar
CF Beginner

Join Date: Jul 2013
Posts: 1

July 20th, 2013, 8:51 AM   #8  
need wiring schematic for neutral safety switch 96 c1500 5.7 4l60e

 
daddytigger75's Avatar
CF Beginner

Join Date: Jan 2015
Posts: 1

January 20th, 2015, 12:24 PM   #9  
Posted By: silverado13 yeah i had to rewire mine because the connectors were stuck in the switch and its a pain, i literally had to cut a wire, soder it and then move to the next, the reason why is because there are 2 green, 2 purple, 3 yellow, 2 pink and 2 black, 11 wires total, and none of them have strips or anything to set them apart from the other same color
DID YOU EVER FIGURE THIS OUT ??? My mechanic just did this same stuff to my truck and messed it up ...

 
badger6891's Avatar
CF Beginner

Join Date: Aug 2015
Posts: 2

August 28th, 2015, 12:26 PM   #10  
I have a 2003 Chevy Blazer 5 spd. Last week when I turned the key, the engine tried to start it, but wouldn't. Each time I tried it the engine became more harder to turn over until it stopped. Now when I turn the key nothing at all happens. No clicking, nothing! I've tried to override the Clutch Safety switch to see if it was bad. Still nothing.... any help or thoughts???
Thanks

 
Tags
Search this Thread
Sponsors
Related Topics