Oil filter Adapter is Leaking - Chevrolet Forum - Chevy Enthusiasts Forums

Oil filter Adapter is Leaking


  Reply  
KGJC616's Avatar
CF Junior Member

Join Date: Apr 2010
Posts: 54
Osceola, Indiana

April 13th, 2010, 10:58 PM   #1  
Oil filter Adapter is Leaking

ok just last week i droped my oil pan to stop it from leaking near the back of the pan. i got it back up the other day and i put oil in the engine and when i went to start it i noticed that my oil filter adapter is leaking. its leaking on the top side of the adapter that meets the block.

I have a 1989 Chevy Silverado C2500 350 5.7L

when i droped the oil pan i droped the oil filter adapter and noticed there was a gasket there so i replaced it with a new gasket. it looked like it was a paper one so im not sure if that is the problem or not but any help would be greatly appreciated. thanks

 
mudmaniac's Avatar
Super Moderator
Ride of the Month
May 2009

Join Date: Jan 2008
Posts: 1,637
Westminster, Md.

April 14th, 2010, 3:22 AM   #2  
Add a little silicon to the gasket and you should be good, make sure the surfaces are clean.

 
KGJC616's Avatar
CF Junior Member

Join Date: Apr 2010
Posts: 54
Osceola, Indiana

April 16th, 2010, 12:24 PM   #3  
thanks for the info i put some RTV on it ill post later if it worked or not.

 
victoria galindo's Avatar
New User
Awaiting E-mail Confirmation

Join Date: Jul 2012
Posts: 1

July 10th, 2012, 2:15 PM   #4  
i replaced oil filter adapter gasket , a few days ago but it dtarted leaking again

 
Top-truck85's Avatar
CF Beginner

Join Date: Jul 2012
Posts: 1

July 10th, 2012, 4:03 PM   #5  
Posted By: victoria galindo i replaced oil filter adapter gasket , a few days ago but it started leaking again
NAPA sells a kit for all the O-rings & gaskets that are associated with the oil filter adapter. Assuming you are talking about the adapter that provides the outlets for the oil cooler. there is a large, thick O-ring that goes up inside that adapter.
Currently, I am having issues with the oil filter gasket blowing out. Does anyone know what is causing this? After each replacement, I can run the truck as long as I want but after it cools and I run it the second time, the oil filter seal starts leaking and I have an oil cooler too. I have a high flow oil pump in a remanufactured block I purchased from JEGS. What could be the problem? Someone said a valve could be sticking? What does that mean. Are they talking about a intake or exhaust valve? I have rebuilt steel heads on the engine as well. it has about 1000 miles on it now. Please offer some suggestions!

 
Tags
Search this Thread
Sponsors
Related Topics