Parking/Running lights won't work? - Chevrolet Forum - Chevy Enthusiasts Forums

Parking/Running lights won't work?


  Reply  
  #1  
Old  March 2nd, 2009, 8:29 AM
  • CF Beginner
    Join Date: Feb 2009
    Posts: 19
Parking/Running lights won't work?

(1993 Chevrolet Silverado) For some odd reason my lights won't work? My headlights work fine, but the dash lights where my speedometer and gauges are don't work and my running lights don't work either. So when i'm driving at night i have no lights in the back unless i push on the break!!! Someone told me that the switch that turns the lights on went out? Also i wired up my halo rings on my headlights and now they don't work idk if that has something to do with it? I don't think the halo's are the reason due to the fact that they worked fine when i hooked them up. Plz help i can't drive legally until it's fixed.


P.S. I checked all of my fuses.

  #2  
Old  March 2nd, 2009, 12:24 PM
  • Super Moderator
    Join Date: Oct 2007
    Posts: 1,274
    Dayton PA
I would say it is probably the switch, or maybe a short which caused the switch to malfunction since in '93 the headlights and running lights are on different switches in the same unit and you said that your headlights still work.

  #3  
Old  March 2nd, 2009, 6:01 PM
do you have the dash brightness turned down
you can fix this by messing with your dome light switch

  #4  
Old  March 2nd, 2009, 8:49 PM
  • CF Beginner
    Join Date: Feb 2009
    Posts: 19
Yeah my headlights still work and i already adjusted the brightness and nothing happens but i can turn the dome light on with the same switch but it doesn't change the brightness because the lights won't even come on. Would anyone know where i could pick up this switch? Autozone? O'reilly?

  #5  
Old  March 3rd, 2009, 6:43 AM
  • CF Beginner
    Join Date: Jul 2008
    Posts: 18
I seem to recall having this problem on one of my same era GM cars and it was the tail light bulb....the dash lights go out to let you know that one of the bulbs has blown. Give it a shot and see if it works...if it does not, then I don't remember that at all!

  #6  
Old  March 3rd, 2009, 11:07 AM
  • CF Beginner
    Join Date: Feb 2009
    Posts: 19
I don't think it can be a tail light bulb cuz my stock tail light bulbs arent't hooked up the L.E.D. rings are hooked up in the back.

  #7  
Old  March 3rd, 2009, 9:08 PM
  • CF Active Member
    Join Date: Sep 2008
    Posts: 221
    LAke Charles, LA
change the switch the contacts get burned out in the switch and quit workin i have changed mine in my 89 twice since i got it because of that same prob i could usually plaw with the switch and get it to work easy way to check is pull the switch and see if you have power on the brown wire comin out with the switch on if not it is the switch if you do then you may have ALOT of burnt bulbs

  #8  
Old  March 4th, 2009, 11:10 AM
  • CF Beginner
    Join Date: Feb 2009
    Posts: 19
Ok well how to do i take the switch out? Is it the torque screws that are on the front? I believe there is 4 of them?

  #9  
Old  March 4th, 2009, 1:30 PM
  • Super Moderator
    Join Date: Oct 2007
    Posts: 1,274
    Dayton PA
Looks like it, those screws hold the bezel on, then you can access the head light switch.

http://www.lmctruck.com/ICATALOG/CD/full.aspx?Page=35

  #10  
Old  June 1st, 2014, 3:47 PM
  • CF Beginner
    Join Date: Jun 2014
    Posts: 1
94 chevy 1500 running/ guage lights

My 1994 chevy 1500 single cab running lights and gauge lights don't work I checked the fuses also. Plus I went ahead and replaced the headed light switch which wasn't the problem. I checked the ground and the trailer hitch T connection. I'm at a total loss at what to try next? Please help? I got pulled over yesterday night and lucky received a warning haha..... Any suggestions???? Thank you

Search this Thread