"SERVICE 4 WHEEL DRIVE" MESSAGE - Chevrolet Forum - Chevy Enthusiasts Forums

"SERVICE 4 WHEEL DRIVE" MESSAGE


  Reply  
BMoTahoe's Avatar
CF Active Member

Join Date: Mar 2008
Posts: 141

May 15th, 2008, 7:55 AM   #1  
"SERVICE 4 WHEEL DRIVE" MESSAGE

It rained for about 3 days straight here in Maryland this past week. When ever it rains, to keep traction control, I always place my 4WD transfer case in "AUTOMATIC". The other day, while I was driving down I-95, I got the "SERVICE 4 WHEEL DRIVE" message on the DIC and the truck went into 2WD. This has happened 3 times before and the service department stated that they had fixed the problem. I pulled into a rest area and shut it down, waited 5 minutes, started back up and got back on the road. When I gotup past Dale City, Virginia the rain got heavy again. I slowed to about 45, went to a slower lane and placed the 4WD transfer case back into 'AUTOMATIC". Not more than 30 seconds later, I got the same message and the truck went back into 2wd. Got home and took it to the dealer the next morning. (My truck only has 5549 miles onit). They had it for 2 1/2 hours, said the problem was fixed, gave it back and I drove off the lot happy. Got up on the Baltimore beltway, looked down at the DIC and there it was again "SERVICE 4 WHEEL DRIVE", and I wasn't in auto this time, I was in 2wd. Took it right back, showed it to the service manager and told them to keep the truck and that I would talk with them through the Maryland Attorney General's Office's Lemon Law rep. That, I think scared them a li'l bit. The service manager himself took the truck back into the service area and went throught it. Didn't take him long to realize his technicians were using the wrong program for the system. He re-programmed it, took it out on a test run and everything was peachy keen. To keep me from calling the emon Law folks, here's what they gave me, FREE oil changes (and I find it beneficial to use synthetic oil) for LIFE, FREE tire rotation for LIFE, 2 FREE tanks of gas and FREE washes for LIFE. Now, let me tell you guys WHY they gave me all of that free stuff. I have a friend who works in the Maryland Attorney General's Office. While my truck was being worked on, I had that friend call the dealership's general manager and they identified themself as a representative of that office, on behalf of me, a service department customer.The caller ID read, MD ATTY GEN. When we got back in from the test ride, the general manager called the service manager into his office. When he came out, I got all thisFREE stuff and a promise that if I ever encounter such a problem in the future, other than routine maintenance, the general will simply replace my truck. When I had the messages show up before and couldn't get satisfaction, I contacted GM and was told that it would take at least 45-60 days for someone to straighten things out. Here, it tooka 5 minute phone call. I've done too many mods to my Hoe to lose it for a trade, but it's good to knowwhen you've got them by the ba--s [8D]

 
Join Date: May 2008
Posts: 14

May 15th, 2008, 8:54 AM   #2  
RE: "SERVICE 4 WHEEL DRIVE" MESSAGE

Good 4 u

 
Join Date: Apr 2008
Posts: 1

May 16th, 2008, 7:45 AM   #3  
RE: "SERVICE 4 WHEEL DRIVE" MESSAGE

I just got the same thing showing on my 07 Tahoe. Was it just a software update or something else. Let me know, I need to take mine in and I can tell them what needs to be done.

thanks
Brent

 
snomon's Avatar
CF Active Member

Join Date: Jul 2007
Posts: 129

May 16th, 2008, 8:49 AM   #4  
RE: "SERVICE 4 WHEEL DRIVE" MESSAGE

A well documented case of "It's not what you know...."

I've had Service 4WD come up a few timesand every time I was in 2WD.Each time I went in the dealer they performed a software update to correct "the glitch" or "bad event error".

 
BMoTahoe's Avatar
CF Active Member

Join Date: Mar 2008
Posts: 141

May 16th, 2008, 10:42 AM   #5  
RE: "SERVICE 4 WHEEL DRIVE" MESSAGE

System programming error is what they told me. When you take it in, make sure you advise them that the 4wd program for the 06's is NOT the same as the 07's as their technicians think it is. That was the mistake they were making with mine.

 
Tags
Search this Thread
Sponsors
Related Topics