02 Tahoe two o2 codes and random misfire. - Chevrolet Forum - Chevy Enthusiasts Forums

02 Tahoe two o2 codes and random misfire.


  Reply  
Join Date: Nov 2007
Posts: 9

November 30th, 2007, 12:48 PM   #1  
02 Tahoe two o2 codes and random misfire.

hello all. I just bought a 02 Tahoe,93k miles,5.3,4x4 ls. Ive got three codes and truck runs rough only on a cold start- 45* or colder.
I'm an ex-gm tech,but electrical was my job, never did much on driveability.
1) p017 bank 1 lean
2) p0174 bank 2 lean
2) p0300 random misfire.

i dont think both o2's would go bad at once since both banks reading lean.i think its something common for all cylinders. i did some matinence;
1) new plugs/wires
2)air filter
3)fuel filter
4)cleaned MAF
5) unhooked vacuum on FPR and no change....

anyone seen this before? going to check fuel press this weekend. scanned again this morning when it was running a little rough and only pulled the 300 code, no o2 codes. any thoughts. clean injectors? bad MAF? gas cap (even though no 400 codes?)
thanks in advance, Gary.

 
Join Date: Nov 2007
Posts: 9

November 30th, 2007, 5:06 PM   #2  
RE: 02 Tahoe two o2 codes and random misfire.

TTT

 
Join Date: Apr 2007
Posts: 423

November 30th, 2007, 6:42 PM   #3  
CF Senior Member
RE: 02 Tahoe two o2 codes and random misfire.

I chased a problem like this on my 97 Z-71 for about 6months, turned out to be the MAF. We even tried cleaning the old MAFwhen chasingdown the problem. This was in 04 and while at SEMA I was speaking with a rep from Granatelli and he suggested for me to try a new MAF, so they overnighted one to the shop and the guys installed one and all my codes went away and power was restored. My problem was mostly at start-up. If I would try to accelerate while cold the truck would stall. Also while trying to pull a load it was very slugish and had poor fuel economy.

Hope you find the problem and Im sure someone will pitch some info in.......

 
Join Date: Nov 2007
Posts: 9

December 4th, 2007, 8:13 AM   #4  
RE: 02 Tahoe two o2 codes and random misfire.

thanks, a local parts store will let me trythe Maf,to see.....

 
Join Date: Jul 2007
Posts: 10

March 20th, 2008, 8:04 PM   #5  
CF Beginner
RE: 02 Tahoe two o2 codes and random misfire.

Did you ever find a fix for your problem? I'm having a similar issue with my '02 Tahoe, but also rough idle when I start in the mornings.

Thanks.

 
Join Date: Nov 2007
Posts: 9

March 21st, 2008, 10:09 AM   #6  
RE: 02 Tahoe two o2 codes and random misfire.

it needs new intake gaskets...i havent changed them yet....

 
Join Date: Jul 2007
Posts: 10

March 21st, 2008, 11:13 PM   #7  
CF Beginner
RE: 02 Tahoe two o2 codes and random misfire.

Thanks for the reply; I hooked up a scanner and read the same codes you have PO171, PO174 and PO300. Sounds like I have the same problem. I read through other posts with similar issues, and recommend cleaning out carbon build up from throttle body. I don't think this will completely solve the problem, but may help a little with rough idle at cold start. If it doesn't help, I'll be seriously looking into replacing intake gaskets.

 
Join Date: Nov 2007
Posts: 9

March 22nd, 2008, 8:07 AM   #8  
RE: 02 Tahoe two o2 codes and random misfire.

yes the intake is plastic[]so,when its cold it leaks....when its warm and expanded it seals better....HTH.

 
Tags
Search this Thread
Sponsors
Related Topics