Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevy Trucks, SUV's, Crossovers & Vans > Tahoe & Suburban
Sign in using an external account
Register Forgot Password?
Search

Tahoe & Suburban The power, space, and brutal towing ability make the Tahoe and its longer sibling, the Suburban, arguably the best full size SUV's on the market today.

2013 Chevrolet Suburban
Platform: GMT 400, 800, 900

Welcome to Chevrolet forum!
Welcome to Chevrolet forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Chevrolet forum today!


Reply
 
 
 
 
LinkBack Thread Tools
  #1  
Old 05-20-2011, 04:04 PM
CF Beginner
 
Join Date: May 2011
Posts: 7
Default Dome light help....Please!!!

I have a 2007 Suburban Z71 that I just purchased. Today while driving the dome/interior light came on and now it won't go off. It stays on when I am driving or parked with vehicle locked. The dome light over-ride button won't turn them off. If I turn the dimmer **** all the way to the right it turn on the other interior lights in the vehicle, otherwise it does nothing. I don't think it's a door pin issue because the DIC doesn't show a door open unless I physically open a door. I have disconnected the battery to see if it would reset anything but no luck. Anybody got any ideas????
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 05-20-2011, 05:32 PM
CF Beginner
 
Join Date: May 2011
Posts: 7
Default

Well, here's an update. I found that there are two fuses that control the interior lighting. One is for the dome lights that come on when you open the door. The other is for the "map" or courtsey lights that you push the button to turn on. I removed the fuse for the "map/courtsey" light fuse and now the lights dim out when I close the door and come on when I open the door as they should. The issue I have now is since I removed the map/courtsey light fuse they don't turn on when the button is pushed, of course. This leads me to believe it is not a door/dome light issue but an issue with the map/courtsey lights coming on and staying on. Any ideas? Will someone post something so I don't feel like I'm talking to my self here????
Reply With Quote
  #3  
Old 05-20-2011, 06:35 PM
in2pro's Avatar
Administrator
2007 Chevrolet Tahoe
 
Join Date: Apr 2008
Location: Austin, Texas
Posts: 5,969
Default

Hummm... maybe check all the interior bulbs for one burnt out?
Reply With Quote
  #4  
Old 05-21-2011, 06:13 PM
CF Beginner
 
Join Date: May 2011
Posts: 7
Default

Sweet.....52 views and only 2 responses, and one of them is mine. Really???? Nobody has any idea that might help me......... Ugh!!!!
Reply With Quote
  #5  
Old 05-21-2011, 08:52 PM
73shark's Avatar
Administrator
 
Join Date: Apr 2006
Location: KC, MO area
Posts: 7,902
Default

That about sums it up. Could be a bad switch that failed closed.
__________________
2010 Sheer Silver Tahoe LTZ (all options but sunroof, power boards), GM (body color flaps, rear console, 3rd row mat, 2-Way Remote, chrome gas door, Esky rack), Eagle Eye LED tails, SLP dual tip exhaust, Silver bow-ties/rear wiper, Catch-All mats, AlphaTherm washer fluid heater, Putco chrome mirror covers, silver calipers, board chrome trim, tint, GMPP Major Guard

2007 Black Tahoe LTZ (Sold),
(GM flaps-$15, Lund Step Tubes-$80-For Sale)
Reply With Quote
  #6  
Old 05-22-2011, 12:24 AM
QUETRANPA's Avatar
CF Active Member
 
Join Date: Sep 2009
Location: Chapel Hill NC
Posts: 189
Send a message via MSN to QUETRANPA
Default

ok you just have to give it some time for more responses since it has only been a few hours since you first posted the question
now it really looks like a bad switch, which one I don't know but wait a minute you just got the truck, the question is did the previous owner do some mods on it? aftermarket radio? amp? alarm system? how long since you got it? is the previous owner still around? I'm sure there's a trick to it but not a word about it at time of sale
now did you search for info and found nothing?
I posted a question too and it took several days for a reply
after all you can live with out those lights for many months (I barely use them) so what's the big deal?
so in conclusion tell us all the story about it, this is a forum, not the magic mirror or a crystal ball!!!
__________________

'07 silverado z71 - black - upgraded to navi unit
'05 colorado (my son drives it )
'04 trailblazer (just sold it to my sis)
'03 silverado fully loaded (traded in for the '07)
Reply With Quote
  #7  
Old 05-22-2011, 12:41 AM
73shark's Avatar
Administrator
 
Join Date: Apr 2006
Location: KC, MO area
Posts: 7,902
Default

I think his problem is that the lites won't go out.
__________________
2010 Sheer Silver Tahoe LTZ (all options but sunroof, power boards), GM (body color flaps, rear console, 3rd row mat, 2-Way Remote, chrome gas door, Esky rack), Eagle Eye LED tails, SLP dual tip exhaust, Silver bow-ties/rear wiper, Catch-All mats, AlphaTherm washer fluid heater, Putco chrome mirror covers, silver calipers, board chrome trim, tint, GMPP Major Guard

2007 Black Tahoe LTZ (Sold),
(GM flaps-$15, Lund Step Tubes-$80-For Sale)
Reply With Quote
  #8  
Old 05-22-2011, 12:16 PM
in2pro's Avatar
Administrator
2007 Chevrolet Tahoe
 
Join Date: Apr 2008
Location: Austin, Texas
Posts: 5,969
Default

Lights are BCM controlled. Might try a reboot, disconnect the battery for several minutes ..
Reply With Quote
  #9  
Old 05-22-2011, 03:54 PM
CF Beginner
 
Join Date: May 2011
Posts: 7
Default

Quote:
Originally Posted by QUETRANPA View Post
ok you just have to give it some time for more responses since it has only been a few hours since you first posted the question 26 hrs after I posted and 52 views. Just looking for I deas.
now it really looks like a bad switch, which one I don't know but wait a minute you just got the truck, the question is did the previous owner do some mods on it? aftermarket radio? amp? alarm system? No aftermarket anything. how long since you got it? Had it a month. is the previous owner still around? Don't know previous owner, bought at dealer several states away and dealer couldn't give me much info. I'm sure there's a trick to it but not a word about it at time of sale
now did you search for info and found nothing? I searched this forum and as much as I could on the web....could not find anyone with similar problem.
I posted a question too and it took several days for a reply
after all you can live with out those lights for many months (I barely use them) so what's the big deal? The big deal is that it is a newer beautiful truck and I like my stuff to work right, apparently you don't. Also I had to pull a fuse to get the lights to shut off. I found that the fuse also turns the instrument pannel lights off so now I can't seem my speedo or guages at night, so kind of a big deal.
so in conclusion tell us all the story about it, this is a forum, not the magic mirror or a crystal ball!!!
I'm not a dummy....I am frustrated and looking for a little help. I appologize if I sounded like this was a "magic mirror or crystal ball" but I belong to a forum for my Harley and am use to getting some quick help. I thought there might be some here and there does appear to be some post here with stuff I can try like froom in2pro. Now, knowing "the story" are you able to provide any intelligent help or did you just post up to tell me that I didn't provide enough info and that I need to be patient?????? Are you a keyboard comando???
Reply With Quote
  #10  
Old 05-22-2011, 05:21 PM
73shark's Avatar
Administrator
 
Join Date: Apr 2006
Location: KC, MO area
Posts: 7,902
Default

My experience on lots of different forums has been that when someone comes on the first time and is critical cuz no one provided any answers within 24 hours usually gets flamed. Can't speak to the Harley forum. Sorry we didn't meet ur expectations.

Since this is the first time I've heard of this problem w/ the NBS, wasn't surprised that there wasn't much response. BTW, did you search the forum?
__________________
2010 Sheer Silver Tahoe LTZ (all options but sunroof, power boards), GM (body color flaps, rear console, 3rd row mat, 2-Way Remote, chrome gas door, Esky rack), Eagle Eye LED tails, SLP dual tip exhaust, Silver bow-ties/rear wiper, Catch-All mats, AlphaTherm washer fluid heater, Putco chrome mirror covers, silver calipers, board chrome trim, tint, GMPP Major Guard

2007 Black Tahoe LTZ (Sold),
(GM flaps-$15, Lund Step Tubes-$80-For Sale)
Reply With Quote
Old 05-22-2011, 05:21 PM
 
 
 
Reply

Tags
07, 2007, dome, forum, gmc, light, lights, map, remove, reset, silverado, suburban, tahoe, turn, wont


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 01:40 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup