Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevy Trucks, SUV's, Crossovers & Vans > Tahoe & Suburban
Sign in using an external account
Register Forgot Password?
Search

Tahoe & Suburban The power, space, and brutal towing ability make the Tahoe and its longer sibling, the Suburban, arguably the best full size SUV's on the market today.

2013 Chevrolet Suburban
Platform: GMT 400, 800, 900

Reply
 
 
 
 
LinkBack Thread Tools
  #1  
Old 12-21-2009, 12:12 PM
CF Junior Member
 
Join Date: Aug 2009
Location: Long Island, NY
Posts: 43
Default Service 4 Wheel Drive???

The only issue I've ever had with my '07 is this damn error message. It comes on sporadically and will go away when I turn the truck off. I've been to the dealer 3 times for it, but unfortunately I can't seem to get there when it's on so I just tell them the issue and hope they fix they it. It really sucks because it's so inconvienent to get to the dealer. Well they obviously have no idea because it happened again yesterday. Can anybody tell me WTF???
Register today for free or log-in if already registered to remove this ad!
__________________
'07 Tahoe LT2 5.3L /Blackbear Performance Tune /K&N Intake /Flowmaster Exhaust
Kenwood DNX8120 /JL Stealthbox
Reply With Quote
  #2  
Old 12-21-2009, 12:43 PM
CF Addict
 
Join Date: Feb 2008
Posts: 2,058
Default camera

keep a small digital camera, or your cell phone most likely has one in the car... snap a pic!

sounds like a faulty sensor to me...
__________________
...Need $, will settle for ...

2009 Tahoe LTZ (Mikayla)
2012 Wrangler Rubicon on 35s (River)
2016 Tesla Model S or X (Saving my )
Reply With Quote
  #3  
Old 12-22-2009, 06:21 AM
CF Beginner
 
Join Date: Dec 2006
Location: pnw
Posts: 29
Default

mine does it too sometimes it will blink service 4 wheel drive. took it to dealer said cant duplicate. i am tired of takin my hoe to dealer waste of time. i just ignored it.
__________________
2007 hoe lt3 white on gray~
so far~ tinted window in front 20%-
momo22-hid 600k-took off all letering.
Reply With Quote
  #4  
Old 12-22-2009, 07:36 AM
CF Junior Member
 
Join Date: Aug 2009
Location: Long Island, NY
Posts: 43
Default

Quote:
Originally Posted by jinzhenheng View Post
mine does it too sometimes it will blink service 4 wheel drive. took it to dealer said cant duplicate. i am tired of takin my hoe to dealer waste of time. i just ignored it.
Was the error on when you were at the dealer?
__________________
'07 Tahoe LT2 5.3L /Blackbear Performance Tune /K&N Intake /Flowmaster Exhaust
Kenwood DNX8120 /JL Stealthbox
Reply With Quote
  #5  
Old 12-22-2009, 08:07 AM
CF Beginner
 
Join Date: Dec 2009
Posts: 3
Default Just Happened to me last night for the first time!!!

Same here, I was turning in "Auto" through a parking lot and the Truck was Bogging down as I turned the steering wheel to pull into the parking stall.I thought that was weird.Sure enough the "SERVICE 4WHEEL DRIVE" sensor kicked on.I proceeded to change the setting to 2 wheel and I heard a loud bang.Assuming that was the hub unlocking itself,sensor went off when I restarted the vehicle.
Reply With Quote
  #6  
Old 12-22-2009, 10:03 AM
CF Beginner
 
Join Date: Dec 2009
Posts: 3
Default

OK,I just took it to the dealership,there was a slip differential from the from the front of the truck and the rear so my computer shut down the four wheel drive.They took it for a test drive and fixed it in about a 15 minutes...
Reply With Quote
  #7  
Old 12-23-2009, 06:46 AM
MDTAHOE's Avatar
Super Moderator
Professional Mechanic
 
Join Date: Nov 2008
Location: Bowie, MD
Posts: 2,955
Default

Mine does it also. It started in this snow storm. I did some reasearch but have not tested anything yet. There is a reflash for the computer to correct this problem. It is in a GM TSB.
__________________
ASE Master Tech, L1 Advance Engine Performance certified
__________________________________________________ ___________________________
I will not answer repair questions by PM, if you would like my input you can PM me and ask me to reply to your public thread.
Reply With Quote
  #8  
Old 12-24-2009, 08:06 AM
CF Beginner
 
Join Date: Dec 2009
Posts: 3
Default

I wonder if the traction control and the 4 wheel drive are throwing each other off???
Reply With Quote
  #9  
Old 12-24-2009, 03:08 PM
CF Junior Member
 
Join Date: Aug 2009
Location: Long Island, NY
Posts: 43
Default

Quote:
Originally Posted by cpadilla13 View Post
I wonder if the traction control and the 4 wheel drive are throwing each other off???
I don't think so. It seems to be random. It happens to me in 4 wheel auto with traction on and it happened the other day when I was in 4 wheel high with the traction control off.
__________________
'07 Tahoe LT2 5.3L /Blackbear Performance Tune /K&N Intake /Flowmaster Exhaust
Kenwood DNX8120 /JL Stealthbox
Reply With Quote
  #10  
Old 01-23-2010, 04:08 PM
CF Beginner
 
Join Date: Sep 2007
Location: Moulton, TX
Posts: 2
Default

My 2000 Tahoe had the Service 4 Wheel Drive light that would come on and off. I took it to the dealer yesterday. They said the 4WD switch on the dash was malfunctioning. I didn't have them change it and today while driving down interstate my tahoe started switching from 2WD to 4WD on its own as a result of the malfunctioning switch. Im not sure yet if anything got damaged. I hope not. I just installed a new transmission on Tuesday.
Reply With Quote
Old 01-23-2010, 04:08 PM
 
 
 
Reply

Tags
07, 08, 2004, 2009, 4wheel, avalanche, chevy, code, drive, fix, message, service, suburban, tahoe, wheel


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Join Chevroletforum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 04:59 PM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup