Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevy Trucks, SUV's, Crossovers & Vans > Tahoe & Suburban
Sign in using an external account
Register Forgot Password?
Search

Tahoe & Suburban The power, space, and brutal towing ability make the Tahoe and its longer sibling, the Suburban, arguably the best full size SUV's on the market today.

2013 Chevrolet Suburban
Platform: GMT 400, 800, 900

Reply
 
 
 
 
LinkBack Thread Tools
  #1  
Old 02-12-2011, 10:27 PM
RJK RJK is offline
CF Junior Member
 
Join Date: Jun 2010
Location: Upstate NY
Posts: 45
Default Service Traction Control - Stabilitrak and ABS light, Help

2007 Suburban 5.3 LTZ

Started up the burban tonight and I have Service Traction Control - Service Stabilitrak and ABS light is on, I'm sure they are all related any ideas?
I searched and found something about a dealer computer upgrade? Does this fall under my 2007 powertrain warranty?

Thanks-
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 02-12-2011, 11:14 PM
73shark's Avatar
Administrator
 
Join Date: Apr 2006
Location: KC, MO area
Posts: 8,009
Default

It might but your warranty book will tell you.
__________________
2010 Sheer Silver Tahoe LTZ (all options but sunroof, power boards), GM (body color flaps, rear console, 3rd row mat, 2-Way Remote, chrome gas door, Esky rack), Eagle Eye LED tails, SLP dual tip exhaust, Silver bow-ties/rear wiper, Catch-All mats, AlphaTherm washer fluid heater, Putco chrome mirror covers, silver calipers, board chrome trim, tint, GMPP Major Guard

2007 Black Tahoe LTZ (Sold),
(GM flaps-$15, Lund Step Tubes-$80-For Sale)
Reply With Quote
  #3  
Old 02-12-2011, 11:25 PM
CF Active Member
 
Join Date: Jan 2009
Posts: 270
Default

if you live in a cold environment, the problem may correct itself. some of the electronics in these trucks do not fancy the cold wet environments of the northeast.
Reply With Quote
  #4  
Old 02-14-2011, 07:31 AM
RJK RJK is offline
CF Junior Member
 
Join Date: Jun 2010
Location: Upstate NY
Posts: 45
Default

I do live in the North East Near Syracuse, NY I drove 240 highway miles yesterday 40 degrees. I thought maybe a wheel speed senser has gone bad. I think that would affect the Traction Control - Stabilitrak and ABS.
I went to the self serve car wash gave all my wheels a good cleaning, disconnected my battery for 10+ minutes started it up and no lights or warnings until I tapped the brake pedal and they all came back.
Reply With Quote
  #5  
Old 05-15-2011, 04:08 PM
fire730's Avatar
CF Beginner
 
Join Date: Mar 2011
Location: New Orleans, LA
Posts: 6
Default

Any more on this issue? Mine just did this and it's not clearing when restarting it. Mine is an 07 with 34k miles. About to go to the dealer in a week or so to get the dash replaced.
__________________
2001 Mustang BULLITT - 28K miles

2004 Yukon XL - 06 Silverado clip - Tahoe 20s - 2/3 drop

2007 Tahoe LT - Wife's Daily - Silverado VHO 20s

1993 Acura Integra
Reply With Quote
  #6  
Old 08-05-2011, 09:17 PM
CF Beginner
 
Join Date: Aug 2011
Posts: 23
Default

Anything new on this? I have a 2007 Silverado LTZ doing the same thing?????
Reply With Quote
  #7  
Old 08-10-2011, 01:42 PM
Official GM Rep
 
Join Date: Mar 2010
Location: Michigan
Posts: 3,536
GMLouisFischer
Default

deepstuff,

I apologize for not seeing this thread sooner. I do not have any information on these lights coming on. Have you let your local dealership know about this issue you are experiencing?

Thank you,

Elizabeth, Chevrolet Customer Service
Reply With Quote
  #8  
Old 08-10-2011, 02:27 PM
CF Beginner
 
Join Date: Aug 2011
Posts: 23
Default

I sprayed my hubs with a garden hose, blindly with the wheels on. The problem has now changed to intermittent. Almost off for a full day. I'll spray them again but now believe it could be corrosion or dirt on the sensors or sensor wheels??

Sounds exactly like the old style truck problem??

Reply With Quote
  #9  
Old 08-13-2011, 11:41 AM
Jimbo B's Avatar
CF Junior Member
 
Join Date: Nov 2010
Posts: 31
Default

I fought this problem for months, door locks, stabilitrack, traction control, gauges going dead or acting erratic, brakes dragging and applying themsevles, and transmission shifting HARD. My 07 Tahoe stayed at the dealership for 3 1/2 months before they figured it out. Here is a list of items they replaced that did NOT help.

Body control module
powertrain control module
Transmission control module
they checked all the connnectors between the Hi and Low speed LAN circuits.
They went as far as telling me that my DVD player which came in the truck was causing the problem... I called bull**** on it. Told them I wanted a factory rep involved and hired a lawyer. The rep got some high paid techs involved and they ended up replacing a terminating resistor in the wiring harness (by the spare tire) and the negative battery cable. It has not done it now for about 6 months.
Reply With Quote
  #10  
Old 08-13-2011, 11:46 AM
Jimbo B's Avatar
CF Junior Member
 
Join Date: Nov 2010
Posts: 31
Default

See the thread " 2007 Tahoe has lost its mind...." its was the positive cable not the negtive that was replaced.
Reply With Quote
Old 08-13-2011, 11:46 AM
 
 
 
Reply

Tags
07, 2007, abs, chevrolet, chevy, controlstabilitrakand, light, lights, service, silverado, stabilitrak, suburban, tahoe, traction, trailblazer


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Join Chevroletforum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 06:29 PM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup