2005 Trailblazer cruise control - Chevrolet Forum - Chevy Enthusiasts Forums

2005 Trailblazer cruise control


  Reply  
mcff2721's Avatar
CF Beginner

Join Date: Jun 2010
Posts: 1

June 20th, 2010, 11:08 AM   #1  
2005 Trailblazer cruise control

Hello everyone, hope someone can help me out. I have a 2005 Trailblazer that the cruise control stopped working on. It started acting up and would only work after i drove for awhile, shut it off and then restarted again. It has completely stopped working and I'm hoping I can get a fix for it before vacation in July(long roadtrip).

 
Chevrolet Customer Service's Avatar
Official GM Rep

Join Date: Mar 2010
Posts: 4,090
Global Headquarters in Detroit, MI

June 22nd, 2010, 7:52 PM   #2  
Have you had your vehicle checked by a local dealership for this issue yet? I would suggest starting there as they would be able to fix it as well. I hope that helps.

Jeff Morris, GM Customer Service

 
Bill's Dad's Avatar
CF Junior Member

Join Date: Oct 2009
Posts: 73

June 22nd, 2010, 9:37 PM   #3  
sounds like a module control type issue to me maybe...You should see if you can gain access to a repair manual 1st to assist you if you want to self repair.

 
rbarrios's Avatar
CF Senior Member

Join Date: Feb 2007
Posts: 339

June 23rd, 2010, 1:31 PM   #4  
is your check engine light on? if it is on- some set codes will disable Cruise.

Any of your tailights burned out? I think Ive read that burned out lights can cause Cruise to not work (though this is iff).

Scan your car for pending codes- (this related to set codes).

 
archebald23's Avatar
CF Beginner

Join Date: Feb 2010
Posts: 19

March 8th, 2011, 11:56 PM   #5  
A good chevrolet trailblazer repair kit or manual would be very fitting in this one. I would rather get some good things there, rather than taking risk on fixing it on my own accord. Plus with the help of the people here, things would have been very much convenient in order to see some ways to solve it.


Last edited by archebald23; March 11th, 2011 at 2:47 AM.
 
PJinOH's Avatar
CF Beginner

Join Date: Apr 2013
Posts: 1

April 17th, 2013, 1:01 PM   #6  
2nd Fuse Block!

I understand that most the replies here are at best 3 yrs old. However, in my lengthy search I came upon this website when I couldn't understand why the brake lights in my '02 Trailblazer LS didn't work but my 3rd brake light did?!? I solve my issue after several days of searching for the answer when it turned out be so simple!

The '02 Trailblazer has a SECOND fuse block under the drivers side back seat. If you still have your manual, it will show you a diagram of it (mine is on page 6-61). There, unlike the fuse block under the hood, this one I.D.'s each fuse. Take a look at #34 15AMP "VEH STOP". Also know that this control's your Cruise Control. I'll bet it's blown?

Ii replaced this fuse and VOILA, ALL brake lights AND cruise control work again, good luck!!

 
Tags
Search this Thread
Sponsors
Related Topics