Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Past Chevy Truck, SUV & Vans > Venture
Sign in using an external account
Register Forgot Password?
Search

Venture 1997-2005
This minivan from Chevy offers a sporty look as well as all of the modern additons of the minivan market.
Platform: U-Body

Reply
 
 
 
 
LinkBack Thread Tools
  #1  
Old 04-30-2009, 01:59 PM
Junior Member
 
Join Date: Mar 2009
Posts: 3
Red face Venture wiper problem

2000 Venture has only high speed on the front wipers. Is this switch problem or wiper motor issue. On the combination switch everything els like turn signals and cruise controls are working.

Has anyone else had this problem and knows if it is the wiper switch or the motor.

Thanks guys
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 06-16-2009, 02:42 PM
CF Beginner
 
Join Date: Jun 2009
Posts: 22
Default

I have the same problem on my 98 Venture !

I've found nothing as of yet.
Reply With Quote
  #3  
Old 06-16-2009, 03:41 PM
EvansBlue's Avatar
Administrator
Ride of the Month
April 2009
2000 Chevrolet Blazer
My Garage
 
Join Date: Jul 2007
Location: Princeton, NC, USA
Posts: 6,161
Send a message via ICQ to EvansBlue Send a message via AIM to EvansBlue
Default

GM had a lot of problems between 1998 and 2002 with the cold solders on the wiper boards.
If you change the wiper motor (and the attached circuit board) the problem will be solved.
My family owned a Suburban that did it, and my Blazer does it occasionally.
__________________
Brent Evans

<br>
Reply With Quote
  #4  
Old 12-19-2009, 07:47 PM
CF Beginner
 
Join Date: Dec 2009
Posts: 2
Default

Only thing with these wiper motors is that they either work or they dont. I just had this exact problem today ..i ended up replacing the wiper switch 260 at autozone or 50 bucks at the bone yard or ebay ..what it did was i had no wipers except high mode takes bout an hour to do if u have all the tools lol ... or 2 beers hope this helps

update note : You do not have to remove the airbag as instructed in the book a simple allen wrench will fit in the one hex screw thats holding the switch in place .

t-25 will be needed for the two screws underneath and a socket torx will be needed when inside the console to remove the top cover

Last edited by tahoefever; 01-07-2010 at 01:37 PM.
Reply With Quote
  #5  
Old 08-02-2011, 12:13 AM
CF Beginner
 
Join Date: Jul 2011
Location: USA
Posts: 2
Default

Quote:
Originally Posted by sajee View Post
2000 Venture has only high speed on the front wipers. Is this switch problem or wiper motor issue. On the combination switch everything els like turn signals and cruise controls are working.

Has anyone else had this problem and knows if it is the wiper switch or the motor.

Thanks guys
Hi! I know this thread is already old but I'm hoping someone here can help me as my front wipers are acting up on me. I've checked the wiring, no sign of ripped off. What do you think is the caused of my faulty wipers?
Reply With Quote
  #6  
Old 09-04-2011, 09:39 PM
CF Beginner
 
Join Date: Sep 2011
Location: Denver, CO
Posts: 2
Default

Have the same problem with my 1999 Venture -- wipers only work intermittently, and when they do, only on high speed setting. Does anyone have a link to the maintenance manual and possibly pictures of the offending part that I need to replace? Any assistance is appreciated!

_erin
Reply With Quote
  #7  
Old 09-06-2011, 12:53 PM
OnThePike's Avatar
CF Beginner
 
Join Date: Jul 2010
Location: New York
Posts: 20
Default

Here's a kicker for you guys. Our 2003 Venture wipers were so bad, the Chevy dealership took weeks to "try" and get them back to "normal". I really think it's a combination of both electrical and mechanical design defects. We replaced the switch, because position 3 dropped dead, and the wiper motor itself, had the arms readjusted and some other internal things changed and they still aren't "factory condition" and the dealer says it's the best he can do LOL!
__________________


Last edited by OnThePike; 10-05-2011 at 10:48 PM.
Reply With Quote
  #8  
Old 09-16-2011, 11:16 AM
CF Beginner
 
Join Date: Aug 2011
Posts: 27
Default

You've Venture has the "military" package. That's why the wipers come to attention and salute once every sweep!

That looks like the linkage to the motor was connected backwards - 180 degrees out.
Reply With Quote
Old 09-16-2011, 11:16 AM
 
 
 
Reply

Tags
2000, chevrolet, chevy, express, forum, high, issues, motor, problem, speed, time, venture, wiper, wipers, work, working


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Join Chevroletforum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 05:48 PM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup