2009 Equinox 3.4 HELP!!!! - Chevrolet Forum - Chevy Enthusiasts Forums

Equinox This SUV offers a smaller, sportier stance than the Trailblazer, all without compromising the SUV abilities.

Chevrolet Equinox
Platform: Theta

2009 Equinox 3.4 HELP!!!!

Reply

 
 
 
Old May 18th, 2018, 8:24 AM
  #1  
CF Beginner
Thread Starter
 
Join Date: May 2018
Posts: 3
Default 2009 Equinox 3.4 HELP!!!!

Ok so I have an 09 Equinox, never had an issue with it then all of a sudden it went into REDUCED ENGINE POWER Mode and shuts down. Then when you go to restart it, it says STARTING DISABLED, SERVICE THROTTLE. The check engine light comes on and give the code p0601 internal control module memory checksum error. After sitting for a few minutes it starts right up and runs fine again. I have taken to the dealership and had the computer re-programmed. thought it was fixed then did it again, was told could be the throttle pedal assembly. Put a new one in and still did it. Somewhere I read online that could be the throttle body or throttle positioning sensor. It seems like it only does it when it gets nice and hot after driving for a long period of time. I see TONS of people asking about this same issue but no actual results! Please someone give me some info on this.
jkait1982 is offline  
Reply With Quote
Old May 18th, 2018, 2:29 PM
  #2  
CF Pro Member
 
Join Date: Sep 2010
Posts: 634
Default

Sounds like an electrical issue to me. Computers go crazy sometimes if they don't get the power they need to operate correctly. Get that battery and alternator tested. A shop should know better. If P0601 was really the only code they got, then replacing any parts wasn't necessary at that point.

I'd also suggest checking your ground connections, disconnect/reconnecting the ECM plug, and inspecting the ECM harness for damaged wires.

This is not as common of an issue as you seem to think it is. There are only a dozen or so Google results on this forum containing "P0601". This forum has been online for about ten years or so, so that's not many instances all things considered.

Last edited by ruley73; May 18th, 2018 at 2:31 PM.
ruley73 is online now  
Reply With Quote
Old May 18th, 2018, 7:47 PM
  #3  
CF Beginner
Thread Starter
 
Join Date: May 2018
Posts: 3
Default

Yeah thatís only code that came up. Any info as to where the grounds are located? Going to inspect the wire harness now
jkait1982 is offline  
Reply With Quote
Old May 18th, 2018, 7:49 PM
  #4  
CF Beginner
Thread Starter
 
Join Date: May 2018
Posts: 3
Default

When itís running the dash is saying the colts for battery are in the mid 14ís
jkait1982 is offline  
Reply With Quote
Old May 19th, 2018, 12:19 AM
  #5  
CF Pro Member
 
Join Date: Sep 2010
Posts: 634
Default

Originally Posted by jkait1982 View Post
When itís running the dash is saying the colts for battery are in the mid 14ís
That's good, but it still doesn't rule out a bad connection or ground somewhere.

Most of the grounds are usually on the driver's side of the engine near where the engine & transmission come together.
ruley73 is online now  
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: