Notices
Equinox This SUV offers a smaller, sportier stance than the Trailblazer, all without compromising the SUV abilities.

Chevrolet Equinox
Platform: Theta

No sound from speakers

Old August 27th, 2010, 6:24 AM
  #1  
CF Beginner
Thread Starter
 
Join Date: Aug 2010
Posts: 2
Default No sound from speakers

I have a 2005 Equinox and the other day I had my back hatch door re-painted. Now that I have it back, there is absolutely no sound coming out of my speakers. The radio and CD player are functioning fine but no sound. I know that they disconnected power to the vehicle in order to paint the rear hatch but they don't know what would cause this.

I spoke with a GM service rep and he said the speakers are probably unplugged. I don't know where the plug is first of all, and I don't know why they would have to unplug speakers to paint. I pulled the radio fuse and reinserted it but nothing changed. Has anybody got any other ideas? Thanks for your help.
equinox05 is offline  
Old August 30th, 2010, 4:01 PM
  #2  
CF Beginner
 
Join Date: Jul 2010
Location: Dela-where?
Posts: 9
Default

there are no speakers in the hatch area....the rear speakers are in the rear doors not the hatch....

do you have premiums sound? if so maybe the rear speakers are somehow linked to the amp on the subwoofer which is located just inside the hatch area on the passenger side...and they unlplugged something there....

id say take it back to the paint shop, and demand they fix it, or else you will have the GM dealer send them a bill along with a letter from your lawyer....
gar187er is offline  
Old August 31st, 2010, 6:17 AM
  #3  
CF Beginner
Thread Starter
 
Join Date: Aug 2010
Posts: 2
Default

Thanks for the response. Just to clarify, there is no sound coming out of ANY speaker in the entire vehicle. I took it back to the body shop and told me the only thing they did was disconnect the battery during the repaint. Understandably, they haven't got a clue what happened either. I'm just trying to understand what may have caused all speakers to stop working or determine where to start troubleshooting. Is there a main connection between the stereo system and all seven speakers? Like I said, the CD and radio operate fine but there's no sound in the vehicle. Thanks.
equinox05 is offline  
Old September 9th, 2010, 9:51 AM
  #4  
CF Pro Member
 
Join Date: Sep 2010
Posts: 679
Default

If you have the premium system (it appears you do since you mentioned 7 speakers), ALL of the speakers are powered by the external amplifier, not just the sub. No power to the amp = no sound at all. Check the fuse for this amp. It should be a 20A fuse in the underhood fuse block labeled "Prem Aud".
ruley73 is offline  
Old June 25th, 2011, 8:29 PM
  #5  
CF Beginner
 
Join Date: Jun 2011
Posts: 2
Default Equinox no sound coming out of speakers

Hello, I just tried what the last person mentioned about the fuse and no luck. I also have the same damn problem and hate that I have no radio. Any other leads would be appreciated. Thanks!
SusieQ62 is offline  
Old June 25th, 2011, 8:31 PM
  #6  
CF Beginner
 
Join Date: Jun 2011
Posts: 2
Default

I tried this with my car with the same problem and it didn't work. Any other suggestions? I appreciate your time!
SusieQ62 is offline  
Old July 28th, 2011, 4:00 PM
  #7  
CF Beginner
 
Join Date: Jul 2011
Posts: 1
Unhappy Possessed speakers

I'm having a similar issue with my 05 Equinox. When I turn the radio on no music comes from the speakers, but I do occasionally get really loud "whump" noises and crackling sounds, even if the radio is turned off. I haven't had any work done on the car, so there's no obvious reason why this could be happening. It's really weird, and the random noises are irritating to say the least Anyone out there have any ideas? I would greatly appreciate any help you can provide!
CBeaupre is offline  
Old July 29th, 2011, 11:30 AM
  #8  
Official GM Rep
 
Join Date: Mar 2010
Location: Global Headquarters in Detroit, MI
Posts: 4,166
Default

CBeaupre,

I am sorry to hear that you are experiencing this issue. Have you consulted your local dealership to confirm the issue?

Thank you,
Elizabeth, Chevrolet Customer Service
Chevrolet Customer Service is offline  
Old June 22nd, 2012, 12:19 PM
  #9  
CF Beginner
 
Join Date: Jun 2012
Posts: 1
Default cargo speaker not working

I have a 2102 Equinox and the cargo speaker has no sound coming out of it. I have heard that there may be no speaker in there at all. How can I tell? I would like to take the cover off of it to investigate but I can't figure that out either. My husband probably will not be as gracefull as me so I would like to figure it out before he gets home
kristenhenson1985 is offline  
Old June 22nd, 2012, 2:06 PM
  #10  
Official GM Rep
 
Join Date: Mar 2010
Location: Global Headquarters in Detroit, MI
Posts: 4,166
Default

<!--[if gte mso 9]><xml> <w:WordDocument> <w:View>Normal</w:View> <w:Zoom>0</w:Zoom> <w:PunctuationKerning/> <w:ValidateAgainstSchemas/> <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid> <w:IgnoreMixedContent>false</w:IgnoreMixedContent> <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText> <w:Compatibility> <w:BreakWrappedTables/> <w:SnapToGridInCell/> <w:WrapTextWithPunct/> <w:UseAsianBreakRules/> <wontGrowAutofit/> </w:Compatibility> <w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel> </w:WordDocument> </xml><![endif]--><!--[if gte mso 9]><xml> <w:LatentStyles DefLockedState="false" LatentStyleCount="156"> </w:LatentStyles> </xml><![endif]--><!--[if gte mso 10]> <style> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} </style> <![endif]--> kristenhenson1985,

The amount of speakers in the vehicle is based on the trim level. The 6-speaker system is standard in the 1LS trim. It includes: 80-watt 6-speaker system, mid-range speakers in each door and tweeters in the A-pillars.

The Pioneer-premium 8-speaker system is available in the 1LT trim, included in an equipment group for the 2LT trim and standard on the 1LZ trim. It includes: Pioneer premium 250-watt 8-speaker system, mid-range speakers in each door, tweeters in A-pillars, a center channel speaker in upper IP and sub-woofer on the rear shelf.

If you would like, PM me the last 8-digits of your VIN, and I will check which is available in your vehicle.

I hope this information is helpful. If you have any additional questions, please feel free to contact me.

Louis
GM Customer Service
Chevrolet Customer Service is offline  

Thread Tools
Search this Thread
Quick Reply: No sound from speakers


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: