Notices
Equinox This SUV offers a smaller, sportier stance than the Trailblazer, all without compromising the SUV abilities.

Chevrolet Equinox
Platform: Theta

No sound from speakers

Old April 23rd, 2013, 12:04 PM
  #11  
CF Beginner
 
Join Date: Apr 2013
Posts: 1
Default

I have a 2000 Impala . my radio is working with stations coming on and cd player working . but no sound.... I found plenty of ideas on the web to repair this problem ... and the one that is most common , is the orange wires under the carpet corroded
. is this something GM will pay for or fix ...
Papaw Weasel is offline  
Old August 3rd, 2014, 2:12 PM
  #12  
CF Beginner
 
Join Date: Aug 2014
Posts: 2
Default

I have a 2012 lt equinox and the only speaker that works is the driver door speaker the rest don't work ??
1qazxsw2 is offline  
Old August 3rd, 2014, 11:38 PM
  #13  
CF Pro Member
 
Join Date: Sep 2010
Posts: 679
Default

Originally Posted by 1qazxsw2 View Post
I have a 2012 lt equinox and the only speaker that works is the driver door speaker the rest don't work ??
Check the Balance and Fader settings on the radio.
ruley73 is offline  
Old August 4th, 2014, 5:52 AM
  #14  
CF Beginner
 
Join Date: Aug 2014
Posts: 2
Default

I did check that but it is not the problem ,they may be disconnected or do they have a separate fuse ??
1qazxsw2 is offline  
Old August 4th, 2014, 1:52 PM
  #15  
CF Pro Member
 
Join Date: Sep 2010
Posts: 679
Default

Did you just buy this vehicle or have you had it a while and the other speakers just suddenly stopped working?
ruley73 is offline  
Old August 4th, 2014, 4:39 PM
  #16  
Official GM Rep
 
Join Date: Mar 2010
Location: Global Headquarters in Detroit, MI
Posts: 4,166
Default

Originally Posted by 1qazxsw2 View Post
I have a 2012 lt equinox and the only speaker that works is the driver door speaker the rest don't work ??


Hello there!

I am sorry you are having this concern with your driver door speaker. Anything we can do to help? Have you contacted your dealership? You are welcome to reach out to us via PM if you'd like our help!

Andraya
Chevrolet Customer Care
Chevrolet Customer Service is offline  
Old August 29th, 2014, 12:51 PM
  #17  
CF Beginner
 
Tanya's Avatar
 
Join Date: Aug 2014
Posts: 1
Default No sound from speakers either!

I also have a 2005 equinox whose speakers went. The radio and cd are working properly, but I get no sound. I did get bumped in the rear passenger side and it did happen shortly after that. I wonder if that is related. I have checked ail connections to the radio and they are fine. Don't know where to start from here. .

Originally Posted by equinox05 View Post
Thanks for the response. Just to clarify, there is no sound coming out of ANY speaker in the entire vehicle. I took it back to the body shop and told me the only thing they did was disconnect the battery during the repaint. Understandably, they haven't got a clue what happened either. I'm just trying to understand what may have caused all speakers to stop working or determine where to start troubleshooting. Is there a main connection between the stereo system and all seven speakers? Like I said, the CD and radio operate fine but there's no sound in the vehicle. Thanks.
Tanya is offline  
Old August 29th, 2014, 8:41 PM
  #18  
CF Pro Member
 
Join Date: Sep 2010
Posts: 679
Default

Originally Posted by Tanya View Post
I also have a 2005 equinox whose speakers went. The radio and cd are working properly, but I get no sound. I did get bumped in the rear passenger side and it did happen shortly after that. I wonder if that is related. I have checked ail connections to the radio and they are fine. Don't know where to start from here. .
If you took a hit in the door jamb, the speaker wires may be shorted. This will cause the radio (or external amp if you have factory subwoofer) to go into protect mode (no sound output) until the short goes away.

If you have the factory subwoofer, then you should also check the fuse for the factory amplifier.
ruley73 is offline  
Old January 22nd, 2015, 1:23 PM
  #19  
CF Beginner
 
Join Date: Jan 2015
Posts: 1
Default no sound from speakers

07 equinox I have tried everything suggested and still no sound from speakers. Changed my stock stereo for another stock stereo, changed amplifier for another stock amplifier, looked at all fuses, inside vehicle and under good. Still nothing. So frustrated. About ayear ago sound started sporadically cutting out, until it just got worse to apoint where there wad no sound at all? Any other ideas?
Alain is offline  
Old January 22nd, 2015, 7:31 PM
  #20  
CF Pro Member
 
Join Date: Sep 2010
Posts: 679
Default

Originally Posted by Alain View Post
07 equinox I have tried everything suggested and still no sound from speakers. Changed my stock stereo for another stock stereo, changed amplifier for another stock amplifier, looked at all fuses, inside vehicle and under good. Still nothing. So frustrated. About ayear ago sound started sporadically cutting out, until it just got worse to apoint where there wad no sound at all? Any other ideas?
I'm thinking that your factory amp isn't receiving a turn-on signal.

The wire that provides the turn-on signal is the white wire located at pin 6 in the C1 factory radio plug and pin 8 in the C3 plug at the factory amplifier. Check for voltage on this wire at the amp. I believe you should get a reading of around 12 volts when the radio is turned on just like the remote lead on an aftermarket radio would provide, but I'm not 100% certain of this. If you get a reading near zero volts then obviously that's your problem, regardless of what the voltage should be. Please let me know what you find either way.

Did you also check the 25A fuse for the factory amp in the instrument panel fuse block?

I've posted links to wiring diagrams for the factory radio & amplfier below to help you troubleshoot the issue.

Radio/Amp 1of2
Radio/Amp 2of2

Last edited by ruley73; January 22nd, 2015 at 7:41 PM.
ruley73 is offline  

Thread Tools
Search this Thread
Quick Reply: No sound from speakers


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: