Notices
Silverado & Fullsize Pick-ups The Silverado has been one of the best selling trucks in the US for decades, and is truly proven to be "like a rock".

2014 Chevy Silverado
Platform: Truck, GMT 400, 800, & 900
Old July 23rd, 2015, 5:07 PM
How-Tos on this Topic
Last edit by: IB Advertising
See related guides and technical advice from our community experts:Browse all: Brakes
Print Wikipost

2008 Silverado cruise control is not working

Old August 2nd, 2011, 6:15 PM
  #11  
CF Beginner
 
Join Date: Aug 2011
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

My 2008 silverado is doing the same thing. Cruise control not working and also tow/haul botton on shifter not working. The dealership put on a brake controler about a week and a half ago. cruise stopped working about 2 days ago. I just left the dealership where they supposedly fixed it. Any clues about what is going on?
ccook is offline  
Old August 3rd, 2011, 9:51 AM
  #12  
CF Senior Member
 
Join Date: Nov 2010
Posts: 368
Likes: 0
Received 0 Likes on 0 Posts
Default

I would suspect the stop light switch especially when you say your brake lights are acting up.
OLD WRENCH is offline  
Old August 3rd, 2011, 12:06 PM
  #13  
Official GM Rep
 
Join Date: Mar 2010
Location: Global Headquarters in Detroit, MI
Posts: 4,166
Likes: 0
Received 0 Likes on 0 Posts
Default

ccook,

I am sorry to hear that you are experiencing this issue. I just want to make sure we are on the same page. You said that you just left the dealership. Did you go back to your dealership and have them fix your cruise control? If so, is it still malfunctioning?

Thank you,

Elizabeth, Chevrolet Customer Service
Chevrolet Customer Service is offline  
Old August 4th, 2011, 6:14 PM
  #14  
CF Beginner
 
Join Date: Aug 2011
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

I didn't have time to go back to the dealership because we were leaving for the beach the next day. On the way to the beach the problem continued and once I noticed the cruise did work but the cruise light on the dash didnt come on. I had a brake controler put on at the dealership and they said the wiring for it was fine. On the way to the beach the trailer brakes stopped working for a while then they came back on. Camper I was towing was about 7000 lbs. so brakes are a must. Seems like others are having similar problems. Any help with this problem would be greatly appreciated. Thanks.
ccook is offline  
Old August 5th, 2011, 1:41 PM
  #15  
Official GM Rep
 
Join Date: Mar 2010
Location: Global Headquarters in Detroit, MI
Posts: 4,166
Likes: 0
Received 0 Likes on 0 Posts
Default

ccook,

I encourage you to have your dealership take a look to see if they can find the issue. If they can’t, let me know and I will get another team involved.

Thank you,

Elizabeth, Chevrolet Customer Service
Chevrolet Customer Service is offline  
Old August 7th, 2011, 9:12 AM
  #16  
CF Beginner
 
Join Date: Aug 2011
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

We just got back from the beach last night and the problems persist. Now the climate control is mulfunctioning. It blows cold air on the passenger side and hot air on the driver side. I had both sides set on 60. Im going to contact the guy that sold me the truck at the dealership and see if they can take it in today. Thanks for your help Elizabeth. Is there an email I can use to keep you up to date with or will you regularly check this thread? Thanks again. Carlton
ccook is offline  
Old August 9th, 2011, 9:15 AM
  #17  
Official GM Rep
 
Join Date: Mar 2010
Location: Global Headquarters in Detroit, MI
Posts: 4,166
Likes: 0
Received 0 Likes on 0 Posts
Default

ccook,

I do my best to monitor the threads I have posted on. If you could e-mail me at [email protected] and put ATTN Elizabeth in the subject line, I would appreciate it. I monitor many different forums and sometimes it is hard to remember every post I have ever made. I look forward to your e-mail.


Thank you,

Elizabeth, Chevrolet Customer Service
Chevrolet Customer Service is offline  
Old August 21st, 2011, 9:35 AM
  #18  
CF Beginner
 
Join Date: Aug 2011
Location: Bradford, Ontario
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default Intermittent Cruise Control solved

I had the same intermittent Cruise Control problem on my 07 Avalanche LTZ. It would work for a while, then just stop engaging. It would start working next time you started up the truck... for a while.
I saw postings in here that it was the brake switch. I tried trouble shooting it... when it was working, I just tapped side of brake pedal and sure enough it tripped it off. I bought a new brake switch rom Chev Dealer ($32.00) and changed it... pretty easy to do.
I noticed that the white grease from the original line installation seemed to be getting into the button on old switch... likely the root cause of the whole problem.
Thanks to others in here for all your help!
Nasboat3 is offline  
Old August 22nd, 2011, 9:11 PM
  #19  
CF Beginner
 
Join Date: Aug 2011
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

You may want to look into getting updated programs in your trucks computer. I was having cruise control problems and also my tow/haul button wasnt working sometimes. Occasionally the temp. compass display would go out too. Most importantly my brake controler would stop working while towing about 7000lbs. and thats not cool. The dealership that sold me the truck said the wiring must be wrong and they wouldnt fix it even though the wiring was done at a Chevy dealership. Truck was still under waranty. I finally went to Terry Labonte Chevrolet and they did a great job at fixing my issues. It seems the wiring was correct. Its probably hard to fix something that only sometimes happens but the new programs seemed to work.
ccook is offline  
Old August 30th, 2011, 6:11 PM
  #20  
CF Beginner
 
Join Date: Aug 2011
Location: Bradford, Ontario
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Smile A/C problems

Originally Posted by ccook View Post
We just got back from the beach last night and the problems persist. Now the climate control is mulfunctioning. It blows cold air on the passenger side and hot air on the driver side. I had both sides set on 60. Im going to contact the guy that sold me the truck at the dealership and see if they can take it in today. Thanks for your help Elizabeth. Is there an email I can use to keep you up to date with or will you regularly check this thread? Thanks again. Carlton
Did you resolve your A/C mix-up problem? I had the exact same thing happen in my 07 LTZ Avalanche after I changed the battery in the ruck. So, I just disconnected the battery and reconnected after a few minutes. Started truck back and they resyn'd and both worked fine.
Nasboat3 is offline  

Thread Tools
Search this Thread
Quick Reply: 2008 Silverado cruise control is not working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: