2009 Silverado LT 1500 electrical problem - Page 2 - Chevrolet Forum - Chevy Enthusiasts Forums
Sponsored by:

2009 Silverado LT 1500 electrical problem


Tdaniel1141's Avatar
New User
Awaiting E-mail Confirmation

Join Date: Oct 2012
Posts: 2

October 25th, 2012, 1:30 PM   #11  
Posted By: Prdgnonr I also have a 2009 1500 Silverado. Recently while driving down the road, all the doors began locking and unlocking no stop. The radio lost sound off and on and the AC quit working. The speedomoter and tech were bouncing up and down also. As I pulled over, I noticed the clicking sounds from the turn signals were also not working. I shut it off for a couple mins and then started it back up. The radio did not seem to have any sound, CD, aux, etc. The AC/Heat had was not working. None of the buttons. I drove it to a gas station and popped the hood and made sure the battery cable was tight and checked fuses. All seemed good. After that I started it back up and everything seemed to be working fine.
One time since then, when I first started the truck, the radio and turn signals had no sound, and after shuting it off and re-starting it, it began to work properly again.
Did you ever take it to a shop and figure out what was wrong? My 1500 is doing the same thing it sounds like.

 
hckyrules219's Avatar
CF Beginner

Join Date: Nov 2012
Posts: 1

November 6th, 2012, 8:36 AM   #12  
elecrtic start problem

I had an after market electric start installed in my 2009 Silverado and when i unlock the doors the radio turns and and as soon as i open the door it turns off. The place that installed it said it is normal for the newer silverado. I was wondering if anyone can tell me this is really normal or not beacuse it does not sound it to me.

I heard that if the truck has to codes AP3 or AP8, the truck might have an electic start in it already. In my glove box there is a sticker that says, Dealer installed AP8 but replaced with AP3. Does this mean my truck might have an electric start already?

 
BobJacq's Avatar
CF Beginner

Join Date: Apr 2013
Posts: 2

April 9th, 2013, 12:44 AM   #13  
2009 Chevy Silverado - Electrical Issue

My wife and I had the same experience. Driving along IH-10 for about 15 minutes when the door locks started going up and down, all the instrument gauges needles bounced up and down and multiple warning lights came on. We turned around and took it to the dealer. We were 5 days from losing warranty. They changed out a master fuse and we did not have any issues for another 2 months. Then it happened again. We took it back in and they kept the truck for a day and a half and could not find a problem. They advised to bring it back when it does it again.

 
BobJacq's Avatar
CF Beginner

Join Date: Apr 2013
Posts: 2

April 9th, 2013, 12:46 AM   #14  
We had the same issue and they changed out a master fuse. No issues for 2 months and then it happened again.

 
clayrog's Avatar
New User
Awaiting E-mail Confirmation

Join Date: May 2013
Posts: 1

May 3rd, 2013, 7:25 PM   #15  
I recently purchased a 2009 Silverado with a 5.3l and I am having similar problems and worse ones also . My transmission shifted into neutral at 70 mph on the highway with the gauges going haywire and door locks clicking up and down . I live in Oklahoma and purchased it at David Stanley Chevrolet used . I purchase a wArranty but has seemed to be useless . This last time it happened we almost got rear ended . I'm afraid of my truck and the car lot won't help me . What can I do ?
Posted By: Chevrolet Customer iService Prdgnonr,
We're sorry to hear about this intermittent electrical concern you're having with your Silverado. Do you think you'll be visiting your local service center to have this checked into? If you would like for us to check into any warranty information on your vehicle, we're happy to do so; please provide the last 8 digits of your VIN.

Sarah (Assisting Louis), Chevrolet Customer Service

 
gto guy's Avatar
CF Beginner

Join Date: May 2013
Posts: 7

May 31st, 2013, 11:05 PM   #16  
The radio in my 09 flashes no disc when shut off & no key in it. Check engine light just came on & track controll started flashing. Arghh I'm VERY dissapointed in gm. I think it has issues when it rains.

 
Chevrolet Customer Service's Avatar
Official GM Rep

Join Date: Mar 2010
Posts: 4,161
Global Headquarters in Detroit, MI

June 1st, 2013, 9:42 AM   #17  
Posted By: gto guy The radio in my 09 flashes no disc when shut off & no key in it. Check engine light just came on & track controll started flashing. Arghh I'm VERY dissapointed in gm. I think it has issues when it rains.

gto guy,

I am sorry to hear you are having these concerns when it rains. I would be happy to look into this situation for you. Can you please private message me your name, phone number, address, VIN, and mileage? I look forward to hearing from you.

Erica Tiffany
Chevrolet Customer Service

 
A-train's Avatar
CF Beginner

Join Date: Jun 2013
Posts: 1

June 27th, 2013, 7:33 PM   #18  
help?

My truck started with the doors locking and gages jumping, local dealer replaced mega 175 fuse, and truck acted right for a month or so. Then it would just loose power for a second and then come back on. they then ran negative wire through truck. Problem continued and then they ran a positive wire, and problem continued. it is still loosing power for a short time and returning to normal and sometimes the stabiltrack flashes off and back on. Have also noticed that cruise control does not wanna work at times. The dealer has a 08 up their now with same problem and they got 38 pages of stuff their looking at, their idea is to find it their and mine should be the same. Has anybody found a answer out their yet, im ready to get this fixed and move on.

 
195zx's Avatar
CF Beginner

Join Date: Feb 2008
Posts: 2

July 31st, 2013, 6:59 PM   #19  
Same problem

Posted By: clayrog I recently purchased a 2009 Silverado with a 5.3l and I am having similar problems and worse ones also . My transmission shifted into neutral at 70 mph on the highway with the gauges going haywire and door locks clicking up and down . I live in Oklahoma and purchased it at David Stanley Chevrolet used . I purchase a wArranty but has seemed to be useless . This last time it happened we almost got rear ended . I'm afraid of my truck and the car lot won't help me . What can I do ?
I have the same problem. Does anyone have a fix for this? It happens so random I can't really figure out what it is.

 
tallboy79119's Avatar
CF Beginner

Join Date: Dec 2013
Posts: 1

December 10th, 2013, 5:37 PM   #20  
PLEASE tell me if ANYONE hasfound the sourceto this problem..... it is rather annoying and localshop says that the computer shows no fault codes the three times I have taken it in to them!

 
Search this Thread
Sponsors