Chevrolet  Forum - Chevy Enthusiasts Forums

Chevrolet Forum - Chevy Enthusiasts Forums (https://chevroletforum.com/forum/)
-   TrailBlazer (https://chevroletforum.com/forum/trailblazer-27/)
-   -   Misfire nightmare (https://chevroletforum.com/forum/trailblazer-27/misfire-nightmare-87349/)

PMC45 December 5th, 2017 1:27 PM

Misfire nightmare
 
So long story short, I have the I6 4.2, 05 trailblazer. It is giving me a cylinder one misfire. I have changed and replaced,
coil packs
plugs
fuel injectors
fuel rail
02 sensor

I am still not getting fuel to cylinder one. Bone dry.
could it be either
a wire issue (which I'll be checking tonight)
bad PCM ( I hope not)
or
a bad crank or cam shaft sensor.

any experience, trick or advice would be awesome thanks in advance.

Paul

kevinkpk December 5th, 2017 3:19 PM

Is this the reason you replaced the injectors? You can prove it's not the injector by swapping it out. The issue stays the same, look for injector pulse, or lack of.

PMC45 December 5th, 2017 3:24 PM

Yes it is. I am gonna (try) injector pulse and voltage tonight. Still learning how to track electrical issues. If there is then I am at a complete loss. Thanks for the direction however.

kevinkpk December 5th, 2017 4:40 PM

Harbor freight has the tester for the injector, looks like an ice pick with a ground clamp. If you're sure it's fuel, go with that. If it's spark, swap plug wires see if it follows.

kevinkpk December 5th, 2017 4:42 PM

It could be a bad PCM, those aren't that expensive. I have a spare out of a 95 pontiac 3.1L

PMC45 December 5th, 2017 9:45 PM

I test ohms and voltage on that injector wire and to that injector. Not the pulse test. Both test were good and within tolerance... So.... PCM or crankshaft.... how much are the PCMs you would say?

kevinkpk December 6th, 2017 3:15 PM

You really need to check for injector pulse. Salvage yard, probably 30-40$

PMC45 December 6th, 2017 3:35 PM

I'll need to surrender to a shop then. And ahhh gotcha.

kevinkpk December 6th, 2017 3:52 PM

That tool is probably less than $10. You had this exact issue before all the work, probably not getting a pulse signal from the pcm, rare those mess up. I can't see it being a sensor since it runs, just misfire on one cylinder.

kevinkpk December 6th, 2017 3:59 PM

https://cimg0.ibsrv.net/gimg/chevrol...352429422d.jpg

4 bucks at harbor freight.


All times are GMT -5. The time now is 6:27 PM.