95 s10 4x4 not working - Chevrolet Forum - Chevy Enthusiasts Forums

Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Past Chevy Truck, SUV & Vans > S-10 & Blazer
Log In 

S-10 & Blazer 1982-2005
The S-10 and Blazer was arguably the most versatile and accessorizable mid-size truck and SUV on the market.
Platform: S/T-series & GMT 330

LinkBack Thread Tools Search this Thread
Old 01-18-2012, 05:30 PM
CF Beginner
Join Date: Jan 2012
Posts: 2
Default 95 s10 4x4 not working

Just got the truck 95 s10 with the push button 4x4. The 4 wheel drive isnt engaging. The light comes on when pushed but only rear wheels spin. Took out the battery checked the actuator for wear. Checked lines and hoses everything looks good. Took a c clamp and pressed in the actuator and put the battery back in, the 4 wheel drive is working and I can still put it into 2 wheel drive. Does this mean that the actuator is bad or is this a vacuum problem? Also is it fine to drive with the c clamp on for a while till i can order parts? We just got 8 inches of snow and are suppose to get another 6 tonight. Really hard to drive this thing anywhere in 2 wheel drive.

Reply With Quote
Old 01-18-2012, 08:39 PM
CF Beginner
Join Date: Jan 2012
Posts: 2

Anybody? I just dont want to do more damage if any by using the c clamp for a day or 2...
Reply With Quote
Old 11-18-2012, 08:33 PM
CF Beginner
Join Date: Nov 2012
Posts: 1
Default S-10 actuator problem

Hey I have found the same problem on my truck. Getting ready to buy that actuator but was wondering if you replaced it and did that solve the problem?
I took it loose down on the bottom and got the 4 wheel drive to kick in so I am thinking that I too need to replace it. Wondering if that was the fix since I have not bought it yet.

Reply With Quote
Old 12-23-2012, 10:10 AM
CF Beginner
Join Date: Nov 2012
Location: Nebraska
Posts: 17

It sounds like a vacuum leak to me if you can manually engage it, run direct engine vacuum to it and see if it locks in. If it does then check your vacuum reservoir and lines and the switch on the transfer case. Something must be leaking somewhere.
04 Chevy Tahoe 5.3
99 Chevy Silverado 4.8
97 Chevy Blazer 4.3
97 Dodge Neon 2.0 DOHC
95 Dodge Neon 2.0 SOHC
85 Chevy K30 M1028 6.2
77 Olds Ninety Eight 6.6

Real Americans drive American
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
98 s10 fuel & temp gauge not working. need help texasrick68 S-10 & Blazer 0 06-15-2013 08:08 PM
1999 s10 4.3 speedometer and odometer not working qureshza S-10 & Blazer 1 12-24-2012 12:03 AM
89 S10 Blazer 4x4 not working jmmarsh72 S-10 & Blazer 0 12-27-2011 09:42 PM
will s10 4x4 700r4 work in full size 4x4 partsfor24 S-10 & Blazer 0 04-18-2007 04:55 AM
88-92 s10 or s10 blazer 4x4 fastfirebird Private 'Wanted' Classifieds 1 11-10-2006 06:20 AM

10, 4x4, 95, actuator, chevrolet, chevy, drive, engaging, forum, install, problems, s10, wheel, work, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -5. The time now is 10:19 PM.