vBLive
Play   Pause

EventByThread/PostForum
New Thread
Gravydog316
Today 1:58 AM
 gold 1,000,000th Mustangs
Cool piece about 50 special gold Mustangs made to celebrate Mustang #1,000,000 in 1966!! ... (18 views, 0 replies)
New Post
73shark
Today 12:49 AM
 2005 z71 suburban coolant and oil issues
Welcome to the forum. Have your radiator cap tested. Do a compression test on the engine. What color is the exhaust smoke at start-up? (105 views, 1 replies)
New Post
CliffS
Yesterday 11:49 PM
 2013 Silverado with rusty bumper...
I have the same issue. Mine is painted the color of the truck. Silver. I have noticed that some models are chrome. There is no problem with those rusting. (1,296 views, 3 replies)
New Thread
Brandon Annis
Yesterday 11:31 PM
 The Swap
I have a 1999 Monte Carlo LS with the 3100 V6 in it. I was wondering what all I would need to do too put a 2006 Impala 3500 V6 engine in it. (78 views, 0 replies)
New Thread
Tony Gamez
Yesterday 10:52 PM
 Knock sensor?
I need yalls help guys.... today while I was checking out my 1984 c10 (305 carb) I noticed a sensor thatís right next to the starter was broken. I have been looking on line on what the sensor could... (90 views, 0 replies)
New Thread
llagge
Yesterday 9:39 PM
 1999- 2006 1500 Silverado New 2" Leveling Kit with shocks
New lift and leveling kit fits Chevy/GMC 99-06 Silverado 2wd $175 obo (75 views, 0 replies)
New Thread
Limey aka Maligoon
Yesterday 9:37 PM
 Cranks but no start
2002 trailblazer 4.2 motor I have put camshaft sensor last week and 5 days later came to stop sign and just died no start.... did some diagnosing and found it might have been crankshaft sensor... (80 views, 0 replies)
New Thread
Victor Vargas
Yesterday 9:28 PM
 Cobalt 2007 broken alarm remote, canít disarm it
i have a cobalt 2007, my remote broke, i opened the door with the key and the alrm started to sound (factory alarm) i turnes the key in the door to disarm it, it didnt work, i turned the engine key,... (76 views, 0 replies)
New Thread
Dalton Swoveland
Yesterday 9:27 PM
 Wanted transmission crossmember for a granny low 3 speed 85 k10
the pic up top is what I need. I'm in Camden Tn close to the river. If you have this I'll figure out a way to get it... (80 views, 0 replies)
New Post
Jamene King Schotsch
Yesterday 8:22 PM
 Service Stabilitrak and Check Engine Light
my 07 torrent is doing the same exact thing, stabilitrack light comes on, lose, power, pull over turn off, restart go for 15 minutes, start again. So I guess I will take it to get the stabilitrak... (202,383 views, 115 replies)
New Post
Sparky Joe
Yesterday 8:16 PM
 Rear Brake Lockup
I had a problem with my 2003 Silverado rear brakes locking up too. Turned out is was bad flexible brake hoses in the rear. Got them changed out and viola! Now works great. :) (274 views, 6 replies)
New Post
intheburbs
Yesterday 5:29 PM
 electrical issue on suburban 2004
"Go crazy at times" isn't exactly specific enough for someone to even take an educated guess at the problem. Try being more descriptive as to the actual behavior. (193 views, 3 replies)
New Post
intheburbs
Yesterday 5:23 PM
 What was the last year ...............??
2006.. (113 views, 1 replies)
New Post
lunghd
Yesterday 4:15 PM
 right rear blinker
It's usually the rear pig-tail. These things are notorious for corrosion. Couple years back I picked up a pair at Amazon and replaced both rear light pigtails. They're like this:... (199 views, 3 replies)
New Thread
Robertlloyd Baldridge
Yesterday 3:02 PM
 Thumping noise after diagnostic tests on afm
First off all afm lifters have been changed, recently I had a misfire on 7 that caused stbilatrac code to come on, took to the shop and the truck decided to quit misfiring on the way there, and act... (97 views, 0 replies)
New Thread
yvesjpm
Yesterday 2:55 PM
 StabiliTrak , service engine light came on.
Driving this morning the StabiliTrak light and service engine light came on. The engine switched to reduced power. I have a 2013 Chevy Malibu with 55K miles on it. I am not sure if its related but... (96 views, 0 replies)
New Post
knjkav
Yesterday 2:03 PM
 theft-deterrent system HELP...
i have found that disconnecting the battery didn't work for me. it might take repeating the process twice or 3 times. you have to leave the key in the on position for 10 min. and turn off then check... (140,766 views, 22 replies)
New Thread
Jesh
Yesterday 2:00 PM
 G20 roof separated from supports
Hey guys was wondering how yíall go about re securing van roofs to supports to reduce road... (89 views, 0 replies)
New Thread
SkyMountain
Yesterday 1:29 PM
 P2123, Reduced Engine Power
I'm not much of a computer guy so this might have been answered. I have been looking but nothing has fixed my problem yet. I suspect it's a ground but I'm not sure how to verify. 2008... (76 views, 0 replies)
New Thread
Neil Williams
Yesterday 12:54 PM
 Accelerator pedal
2006 Chevrolet Impala 3.9 V-6 LT automatic When I replace the accelerator pedal, do I have to re program or, can I just unhook the negative battery cable? Thanks a lot people for your help. (91 views, 0 replies)
Sponsors