Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevy Trucks, SUV's, Crossovers & Vans > Silverado & Fullsize Pick-ups
Sign in using an external account
Register Forgot Password?
Search

Silverado & Fullsize Pick-ups The Silverado has been one of the best selling trucks in the US for decades, and is truly proven to be "like a rock".

2014 Chevy Silverado
Platform: Truck, GMT 400, 800, & 900
Sponsored by: Bakliner

Reply
 
 
 
 
LinkBack Thread Tools
  #1  
Old 07-30-2010, 01:10 AM
CF Beginner
2005 Chevrolet Silverado 1500
 
Join Date: Jul 2010
Posts: 1
Default "service 4-wheel drive"

i am new to this site so forgive me if this has been posted before. i have a 2005 Chevy Silverado Z71 the service 4-wheel drive message appears on the message display on my dash. it started a while back being an every once in a while occurrence, the first thing i assumed was to check the fluids and i added what needed to be added. that did not fix my my problem it still came on every once in a while and now the service 4 wheel drive message stays on constantly. it is push button 4 wheel drive. so the problem is when i start my truck sometimes the light beside the neutral display will be red, other times there are no lights indicated at all, and the other times when i start my truck it will be in 4L or 2H...... i know by my research that this is a known problem but i haven't found someone that has the exact same problem i am having. when i start my truck and there are no lights showing on my push button indicator, i don't know if it is in 2 or 4 wheel drive so i turn the truck off and on till lights are showing on the push button indicator, at that time if the light indicates it is in 4 wheel drive i can put in in neutral and push 2H and it changes fine. if my lights are on and i can change it from 2 to 4 wheel drive my switch should be good. it is very confusing and i hope my explanation is easy to understand so i can get some much needed input...... thanks in advanced
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 12-11-2010, 11:56 AM
CF Beginner
 
Join Date: Dec 2010
Location: San Bruno, California
Posts: 1
Default

I had the same message and took it to the dealer. $360 later they said there was nothing wrong with my truck. I went to Tahoe just before Thanksgiving and it snowed the entire four days. I had the truck in 4WD the whole time, due to the road conditions, and when I returned to the low lands, the service 4WD light came on. I'm taking it back to Chevy to see what's happening.
Reply With Quote
  #3  
Old 10-02-2012, 07:05 AM
New User
Awaiting E-mail Confirmation
 
Join Date: Oct 2012
Posts: 1
Default

Have either of you found the solution? My truck has the exact symptoms of CHEVYFAN4LIFE's post.
Reply With Quote
  #4  
Old 10-02-2012, 01:53 PM
CF Active Member
 
Join Date: Dec 2010
Location: Clovis, CA
Posts: 130
Default

Have two 2001 4x4 Silverados, a 2500hd and a 1500, both with electronic switch, also have a 1999 1500 with 4x4 floor shift. The 2001 1500 had the 4x4 message when I bought it. My first repair was the switch as most posts had stated being bad. Replaced switch with cheap chinese crap as dealers were way past my pocket book.. Did not fix so next replace the transfer motor located on the transfer case. After 3 chinese crap went to a rebuilt american made and still had problems. Next replaced the transfer module which on my trucks is located behind the dash on the left side. Found a used one with the same mfg # on E-bay and were back in business. So my thought is after all the parts replaced it was the module.. By the way put old switch back in.. Also there is a master ground at least on my trucks located under drivers door on the body/frame support rail looking forward. Hope this helps

Last edited by ToooTall1; 10-02-2012 at 02:13 PM.
Reply With Quote
  #5  
Old 10-06-2012, 07:29 AM
CF Junior Member
 
Join Date: Sep 2012
Posts: 34
Default

I had that exact problem with my '05 Z71. After replacing the transfer case and actuator (grinding noise) it still didn't work. Took it to a dealership where they replaced a corroded with and some connectors. Cost me $300. I live in Maine where the underside of the truck is always wet in the winter. Good luck.
Reply With Quote
  #6  
Old 11-25-2012, 05:43 PM
Captaintek's Avatar
CF Beginner
 
Join Date: Apr 2010
Location: Springfield, IL
Posts: 4
Default

I have had the same intermittant problem with the electronic shifter locking up in 4-wheel drive on my 2000 Silverado. I would push the 2-wheel drive button many times before it would go back into 2-wheel drive. I never could get the all-wheel drive to engage. After almost 2 years of owning it, I finally decided to try and fix it myself. I popped off the dash bezel and then removed the switch. After taking it apart, I could see a solder connection that looked bad, but due to my poor soldering skills, I decided to look for a replacement. The OEM part number was 15570927 on my 2000 Silverado, which I was able to find a Dorman replacement (901-062) on Autozone website for $64.99 plus tax. I drove to my local store and it took me about 10 minutes to put it all back together. Now when I push on any of the buttons, the transfer case changes just like it should, even the all-wheel drive works now. Good Luck on your truck!
__________________
2000 Silverado 1500, Extended Cab, 4x4
Reply With Quote
  #7  
Old 11-27-2012, 04:45 PM
CF Beginner
 
Join Date: Nov 2012
Posts: 2
Default 4WD service light

having the same issues with my 03 Suburban i changed the switch on the dashboard and disconnected my battery for about 30 minutes to reset the computer and I still have the same problem I cant switch from 4Wd to any other options the only time I can switch when I first turn on the car and press the desired button simultanously can anyone help me or give me advise I live in NJ and some dealers over here will just rob you blind

Last edited by boriqua_man_99; 11-28-2012 at 09:56 AM.
Reply With Quote
  #8  
Old 11-29-2012, 05:27 PM
CF Junior Member
 
Join Date: Feb 2009
Location: DFW, Texas
Posts: 31
Default

I had the same problem on my 2000 Chevy Silverado Z71 extended cab. The push button lights acting screwy. Had a hard time getting it into and out of 4 wheel drive. The shop replaced the solenoid and it fixed the problem. No more 4 WD light, push buttons work everytime and indicate the correct status.
Reply With Quote
  #9  
Old 02-03-2013, 07:24 AM
CF Beginner
 
Join Date: Feb 2013
Location: West Wyoming Pa.
Posts: 1
Default

Just 2 days ago I had the same problem. I went to the dealer and they scanned the code for free. It was tmto order the motor. $238.00
Reply With Quote
Old 02-03-2013, 07:24 AM
 
 
 
Reply

Tags
2005, 4wheel, button, check, chevy, displays, drive, light, means, problem, push, service, tahoe, truck, wheel


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Join Chevroletforum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 03:55 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup