Notices
Silverado & Fullsize Pick-ups The Silverado has been one of the best selling trucks in the US for decades, and is truly proven to be "like a rock".

2014 Chevy Silverado
Platform: Truck, GMT 400, 800, & 900
Old August 10th, 2015, 11:32 AM
How-Tos on this Topic
Last edit by: IB Advertising
See related guides and technical advice from our community experts:Browse all: Interior Guides
Print Wikipost

2007 Silverado: disconnected battery, now won't crank

Old July 15th, 2010, 9:33 PM
  #11  
Administrator
 
in2pro's Avatar
 
Join Date: Apr 2008
Location: Austin, Texas
Posts: 7,526
Likes: 0
Received 0 Likes on 0 Posts
Default

Welcome to the forum..
what year model and engine to you have flog62?
I'm guessing its not an issue of the battery being discharged....
in2pro is offline  
Old July 15th, 2010, 9:40 PM
  #12  
CF Beginner
 
Join Date: Jul 2010
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
Default

2007 5.3 new body style. Its not the battery, I load tested it and everything checked out fine. If you have any ideas, I would really appreciate it. I have been searching for 3 days and this is the first I have seen that resembles my problems. I am really starting to get frustrated and getting worried that the mechanic is not real for sure what is going on either.

Last edited by flog62; July 15th, 2010 at 10:01 PM.
flog62 is offline  
Old July 15th, 2010, 10:02 PM
  #13  
Administrator
 
in2pro's Avatar
 
Join Date: Apr 2008
Location: Austin, Texas
Posts: 7,526
Likes: 0
Received 0 Likes on 0 Posts
Default

on the firewall near the battery there is junction for the positive battery cable, I believe this is a fuse-able link, check it.
in2pro is offline  
Old July 15th, 2010, 10:14 PM
  #14  
CF Beginner
 
Join Date: Jul 2010
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
Default

I have and I get fire on both sides. Keep firing ideas, because I am out of 'em. I feel like I have tried everything, but there has got to be something that I am missing.
flog62 is offline  
Old July 15th, 2010, 10:17 PM
  #15  
CF Beginner
 
Join Date: Jul 2010
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
Default

I would like to know if the lady that started this thread resolved her problem and would really like to find that reset button she spoke of lol.
flog62 is offline  
Old July 15th, 2010, 10:23 PM
  #16  
Administrator
 
in2pro's Avatar
 
Join Date: Apr 2008
Location: Austin, Texas
Posts: 7,526
Likes: 0
Received 0 Likes on 0 Posts
Default

Yeah that is the bad part, folks get there vehicle going and some never come back and update what did and didn't work... Im hoping they got it fixed and are on their vacation and when they get back she will update us....

Have you tried disconnecting the battery?
in2pro is offline  
Old July 15th, 2010, 10:26 PM
  #17  
CF Beginner
 
Join Date: Jul 2010
Location: San Diego, Stockton
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default

Im guessing the alarm isn't an issue.lol
frais is offline  
Old July 15th, 2010, 10:28 PM
  #18  
CF Beginner
 
Join Date: Jul 2010
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
Default

Yes. That was one of the first things that I did, thinking that it would reset. I literally pulled every fuse and relay, whether it had anything to do with starting or not. Switched the crank/run relay with another good one, turned out I could actually hear the relay clicking when I turned the key on.
flog62 is offline  
Old July 15th, 2010, 10:32 PM
  #19  
CF Beginner
 
Join Date: Jul 2010
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
Default

I dont think the alarm has anything to do with it, but I may be wrong. I can not use the remote to lock/unlock the doors, the panic button does'nt even work, but the horn will blow when pushed.
flog62 is offline  
Old July 15th, 2010, 10:35 PM
  #20  
CF Beginner
 
Join Date: Jul 2010
Location: San Diego, Stockton
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default

..There was hella tricks to my uncles alarm.
There was the alarm going haywire and you had to lock and unlock the car doors like 3 times and the holding the alarm reset button and turning your engine on. This also happens if you're alarm was disconnected. You may have loose wires maybe.
frais is offline  

Thread Tools
Search this Thread
Quick Reply: 2007 Silverado: disconnected battery, now won't crank


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: