1999 K1500 starts but stalls right away - Chevrolet Forum - Chevy Enthusiasts Forums

1999 K1500 starts but stalls right away


  Reply  
Join Date: Sep 2008
Posts: 1

September 12th, 2008, 8:11 AM   #1  
1999 K1500 starts but stalls right away

I bought this truck not running, knowing it needed a fuel pump and a new intake gasket. I replaced both and have everything put back together. The truck will start, but stalls out right away. It will restart, but continues to stall right away. The fuel pump I used was an airtek, and it required me to replace the wiring harness at the pump. I think I did that right since it starts (so I have fuel pressure when it starts). My guess is that the fuel pump is shutting off as soon as the truck starts, but not sure what is causing it. Could this be the fuel pressure regulator, faulty pump, crank sensor, etc? I would appreciate any help.

Thanks

 
shawnvw's Avatar
Super Moderator
Professional Mechanic

Join Date: Jan 2008
Posts: 2,571

September 12th, 2008, 1:24 PM   #2  
RE: 1999 K1500 starts but stalls right away

sounds like a problem in the passlock system
Turn the key on and watch the security light....does it flash? if so, leave the key in the on position for 10mins (or until the light stops flashing), turn the key off, then start the vehicle

 
x1cn18's Avatar
CF Active Member

Join Date: Sep 2008
Posts: 221
LAke Charles, LA

September 13th, 2008, 11:02 AM   #3  
RE: 1999 K1500 starts but stalls right away

could possibly be thr regulator also try holding about quartet throttle and try to start mine is going out and it does the same thing if it is cold

 
Tags
Search this Thread
Sponsors
Related Topics