Go Back   Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevy Trucks, SUV's, Crossovers & Vans > Silverado & Fullsize Pick-ups
Sign in using an external account
Register Forgot Password?
Search

Silverado & Fullsize Pick-ups The Silverado has been one of the best selling trucks in the US for decades, and is truly proven to be "like a rock".

2014 Chevy Silverado
Platform: Truck, GMT 400, 800, & 900
Sponsored by: Bakliner

Reply
 
 
 
 
LinkBack Thread Tools
  #11  
Old 01-15-2014, 02:57 PM
CF Beginner
 
Join Date: Dec 2013
Posts: 5
Default Good News, Bad News

The good news is after a month and 3 days my 2014 Chevy Silverado is back in my driveway. The pinion bearing in the rear differential needing replacing and due to it being a new model, GM didn't have the parts readily available.

The bad news is the reception still SUCKS on my FM radio!!! Truly awful and full of static on stations that normally come in clear in other vehicles. The dealer said they checked everything out and even drove it around with another truck to see how it compared. They said it was comparable. So nothing was done. The reception is so bad, I am seriously considering trading in the vehicle with 1,000 miles on it and taking the loss. Too bad, because it is a beautiful truck.

I called Crutchfield and after asking me a few questions they said it's most likely the tuner and I'm pretty much SOL. Not happy.
Register today for free or log-in if already registered to remove this ad!

Last edited by Ray Ray; 01-15-2014 at 03:01 PM.
Reply With Quote
  #12  
Old 01-26-2014, 09:31 PM
CF Beginner
 
Join Date: Nov 2013
Location: Round Rock, TX
Posts: 8
Default

Quote:
Originally Posted by airforceret View Post
I replaced my factory fender antenna with an after market and have great FM reception. My XM reception still sucks but the local satellite radio dealer says it's an inherent problem with the poor quality roof antenna installed by GM. We proved this by running an external antenna and aftermarket XM portable receiver for a few weeks with no problems.
What after market antenna did you use? Thanks for the help
Reply With Quote
  #13  
Old 03-03-2014, 08:54 AM
3rd Chevy trk's Avatar
CF Beginner
 
Join Date: Mar 2014
Posts: 1
Default

Just bought a 2014 1500 crew. FM reception terrible. Salesman said GM is working on it?? I am interested in what antenna you went with.
Reply With Quote
  #14  
Old 03-04-2014, 08:34 AM
CF Beginner
 
Join Date: Dec 2013
Location: Florida
Posts: 4
Default

Quote:
Originally Posted by 3rd Chevy trk View Post
Just bought a 2014 1500 crew. FM reception terrible. Salesman said GM is working on it?? I am interested in what antenna you went with.
I didn't go with any antenna... I took it to the dealership and they put a plain ol' regular fender antenna on it. That's complete BS if they're telling people it's comparable so they aren't doing anything. Hey Detroit! Make an effin truck with a good ol FM radio. Jesus....
Reply With Quote
  #15  
Old 03-06-2014, 08:58 AM
CF Beginner
 
Join Date: Dec 2013
Posts: 5
Default

My dealer spoke with a GM engineer that lives in my area and drives a new 2014 Chevy Silverado. He says the radio reception is a known issue and acknowledges the reception is poor. The engineer also stated that there is no planned fix as of this time.

My recommendation is for people to continue to complain and to complete your Chevy survey.
Reply With Quote
  #16  
Old 03-06-2014, 10:14 PM
Pugly's Avatar
CF Active Member
 
Join Date: Feb 2014
Posts: 152
Default

Quote:
Originally Posted by Chevrolet Customer Service View Post
Hey xthefifthx,

We're glad to see the issues with your antenna have been resolved. We love reading this kind of news! Please feel free to contact us in the future with any questions or concerns.

Amber N.
Chevrolet Customer Care
I find it pathetic that this "customer no-care rep" has only made a comment on the one truck that was fixed and has offered no help to all of you who are having the same problem with no results.

There is obviously a problem. Too bad they don't care enough to resolve it.

I'll bet if it one of the service techs or service writer was having the same issue they would have fixed it by now.
__________________
Pugly - a 2011 2500HD WT
4x4 6.0L Plain Jane
Regular cab
No power anything
Incredible world class sound system
Reply With Quote
  #17  
Old 03-09-2014, 09:29 AM
CF Junior Member
 
Join Date: Apr 2013
Location: South Shore Mass
Posts: 30
Default

Is there only one type of radio in the 2014's, the one with the nav?
Reply With Quote
  #18  
Old 04-29-2014, 02:15 PM
Algonkin's Avatar
CF Beginner
 
Join Date: Apr 2014
Location: Embrun, Ontario, Canada
Posts: 11
Default

I have the same problem with the radio signal as well. I noticed it as soon as I picked it up from the dealer. I thought it was just me but thanks to this forum, I'm getting some issues addressed. Thanks Ray Ray for posting this. I will mention this to my dealer.
Reply With Quote
  #19  
Old 04-30-2014, 04:58 PM
CF Beginner
 
Join Date: Nov 2013
Location: Round Rock, TX
Posts: 8
Default One type of radio?

Quote:
Originally Posted by mad max View Post
Is there only one type of radio in the 2014's, the one with the nav?
No, there is a basic non-nav radio with a small screen (I think it is 4 inches) and then there is a 8 inch screen with Nav and also Bose version. As far as I know, all of these are having the issues. There is a thread on GM-Trucks.com where a member is working with an engineer. They visited him, reproduced the issue and are now trying to determine a fix. They think it has to do with how the radio handles lower signal stations - it actual switches to mono vs. stereo and then HD drops altogether which, in turn sounds horrible. Keep bringing it up and letting GM know how bad it is. Thanks
Reply With Quote
  #20  
Old 05-01-2014, 02:47 PM
Algonkin's Avatar
CF Beginner
 
Join Date: Apr 2014
Location: Embrun, Ontario, Canada
Posts: 11
Default

Quote:
Originally Posted by Chuckl1218 View Post
There is a thread on GM-Trucks.com where a member is working with an engineer. They visited him, reproduced the issue and are now trying to determine a fix.
You wouldn't happen to have a direct link to that thread would you?
Reply With Quote
Old 05-01-2014, 02:47 PM
 
 
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Join Chevroletforum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 06:26 PM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

Emails Backup