05 Chevy 1500 LS 2wd Trans issues? - Chevrolet Forum - Chevy Enthusiasts Forums

1999 - 2006 (GMT800) Section for all discussion related to the 1999-2006 Chevrolet and GMC trucks.

05 Chevy 1500 LS 2wd Trans issues?

Reply

 
 
 
Old June 11th, 2018, 12:10 PM
  #1  
CF Beginner
Thread Starter
 
Join Date: Jun 2018
Posts: 2
Default 05 Chevy 1500 LS 2wd Trans issues?

Stock Transmission was rebuilt 2 previous times over a 6 year period. Broke a 3rd time by that point we figured a third rebuild was overkill. If after only 3 yrs itd break again. We bought a brand new one & a brand new torque convertor. One week after putting the new one in it blows. Note: no codes, no issues before trans issues. It did get a new rear end after the 2 rebuilt trans. i know there was a few ideas my fiances had of causes but so far everything he could think was all perfect.
Kate.Wal is offline  
Reply With Quote
Old June 11th, 2018, 12:40 PM
  #2  
CF Addict
 
oldchevy's Avatar
 
Join Date: Apr 2012
Location: Miami, FL.
Posts: 3,266
Default

Who is rebuilding these for you? If the last one was new, then it should be under warranty!
oldchevy is offline  
Reply With Quote
Old June 11th, 2018, 1:00 PM
  #3  
CF Beginner
Thread Starter
 
Join Date: Jun 2018
Posts: 2
Default

Originally Posted by oldchevy View Post
Who is rebuilding these for you? If the last one was new, then it should be under warranty!
the new one is under warranty & its in the process of being fixed. We are just curious if something else maybe causing the trans to keep breaking.
Kate.Wal is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: