Notices
1999 - 2006 (GMT800) Section for all discussion related to the 1999-2006 Chevrolet and GMC trucks.

no power whatsoever in 2003 Silverado

Old October 11th, 2018, 3:01 PM
  #1  
CF Beginner
Thread Starter
 
Join Date: May 2009
Posts: 13
Default no power whatsoever in 2003 Silverado

I parked my 2003 Silverado yesterday and everything was fine. When I went to start it today, I have no power any where in the vehicle, but the battery is fully charged. I checked the ground wire from the battery to the engine block and that is okay. The ground wire from the firewall to the engine block is also okay. Where do I go from here?
Larrycarol is offline  
Old October 11th, 2018, 3:54 PM
  #2  
CF Senior Member
 
Join Date: Aug 2018
Location: Adirondacks,ny
Posts: 361
Default

Failure at battery,cable end shot?give it a good look over,both of them
geo1 is offline  
Old October 12th, 2018, 9:32 AM
  #3  
CF Beginner
Thread Starter
 
Join Date: May 2009
Posts: 13
Default

Checked that - everything OK there, too.
Larrycarol is offline  
Old October 12th, 2018, 9:35 AM
  #4  
CF Senior Member
 
Join Date: Aug 2018
Location: Adirondacks,ny
Posts: 361
Default

?, positive off of battery splits,small one to underhood fuse and relay center, problem under there?
geo1 is offline  
Old October 12th, 2018, 9:38 AM
  #5  
CF Senior Member
 
Join Date: Aug 2018
Location: Adirondacks,ny
Posts: 361
Default

I meant,starter where it splits
geo1 is offline  
Old October 12th, 2018, 9:41 AM
  #6  
CF Beginner
Thread Starter
 
Join Date: May 2009
Posts: 13
Default

In the past, the past the information center has jumped from one language to another on it's own and sometimes I've gotten an icon showing that looks like a padlock around a doorpost, even though everything seems to be working okay. I'm wondering if the onboard computer has gone bad. If that happened, would it kill power to everything?
Larrycarol is offline  
Old October 12th, 2018, 9:45 AM
  #7  
CF Senior Member
 
Join Date: Aug 2018
Location: Adirondacks,ny
Posts: 361
Default

Hopefully a intermittent power issue?now total failure?gonna need a test lite,start checking large fuses in relay,fuse center
geo1 is offline  

Thread Tools
Search this Thread
Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: