Notices
Avalanche Chevy's first real SUT, combining the interior room of an SUV and the cargo ability of a pickup truck.

Chevrolet Avalanche
Platform: GMT 805 & 900

2007 Chevrolet Avalanche Transmission Failure

Old July 11th, 2019, 11:42 AM
  #1  
CF Active Member
Thread Starter
 
Join Date: Dec 2018
Location: Virginia
Posts: 106
Received 0 Likes on 0 Posts
Default 2007 Chevrolet Avalanche Transmission Failure

Son has a 2007 Chevrolet Avalanche 4x4 with 187K miles. Transmission rebuilt over 18 months ago (rebuild warranty has expired).

A few evening ago there was a sudden vibration and the vehicle lost all forward motion. Putting the vehicle in park does not hold the vehicle - there is a clunking sound. Reverse and neutral are fine, but when it is put in Drive it makes a horrible racket and the vehicle will not move forward. He's checked the Universal joints - all appear to be fine.

Any ideas as to what may have failed? He's planning on getting it repaired if the cost isn't too high and then selling or trading it.

Note - I am 400 miles from him and only heard the sound over the phone.
Doug D is online now  
Old July 11th, 2019, 1:00 PM
  #2  
CF Active Member
 
Join Date: May 2015
Posts: 220
Likes: 0
Received 11 Likes on 10 Posts
Default

I hate to tell you this but it's going to need to be opened up to determine what failed. If park won't hold, something is broken as the parking pawl engages a notched wheel that attached to the shaft. Did it get inadvertently shifted into park while moving? Does 1 or 2 do anything?

Here's a list of 30 common problems with the 4L60e. 30 Common 4L60e Problems

Maybe the splines on the shaft were damaged inside the trans.

I wouldn't mess with it any. It'll need to be opened up and examined.

Last edited by KChevy75; July 11th, 2019 at 1:03 PM.
KChevy75 is online now  
Old July 11th, 2019, 1:40 PM
  #3  
CF Active Member
Thread Starter
 
Join Date: Dec 2018
Location: Virginia
Posts: 106
Received 0 Likes on 0 Posts
Default

He didn't move into 1 or 2. As soon as he put it in D it made a horrible ratcheting sound - loud enough I could hear it via his cell phone which was on speaker. I suspect something with the parking pawl went bad. As far as I know he did not put it in Park while moving but I suppose that is possible.

He has it scheduled to go to a transmission shop (same one that rebuilt it) next Monday - that's the earliest they can look at it. It may be a few days before they have a diagnosis.

I do know when the transmission failed the first time, 1st and 2nd gear worked fine and it was hesitant to go into 3rd and would not go to 4th. Supposedly the entire transmission was rebuilt.

Pending the diagnosis, his plans are to repair it and then sell it. He's had enough of it and is tired of only getting 13 mpg no matter what he does.
Doug D is online now  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: