Notices
Classic Trucks (Prior to 1987) Section for all discussion related to the Classic Chevrolet and GMC trucks prior to 1987.

knock signal issue

Old September 11th, 2016, 6:25 PM
  #1  
CF Beginner
Thread Starter
 
Join Date: Sep 2016
Posts: 1
Default knock signal issue

looking for answers.. i have a 1987 350 tbi. the issue is backfiring through the intake when quickly accelerating, and lack of power. codes never come up usually but once i got code 43. the code reader i have shows a knock signal of 17 that i cant get rid of. i unplugged the new sensor i put in and the signal stays at 17, shouldnt it go to 0? also when i unplug the ESC the knock signal goes wacko, with every refresh of the reader i see anywhere from 300 to 4 counts!! what in the crap id the deal? when i ran through the troubleshooting logic chart for code 43 i ended up at the CKT 485 open, shorted to ground or bad ECM, ran a new wire to ECM and replaced ecm but same issue. according to the chart my ESC shouldnt have an issue but im not so sure that it is not the culprit.
sheajk is offline  

Thread Tools
Search this Thread
Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: