Go Back  Chevrolet Forum - Chevy Enthusiasts Forums > Current Chevy Trucks, SUV's, Crossovers & Vans > Equinox
Reload this Page >

Service Stabilitrak, Traction Control lights ON, alone with check engine light...

Notices
Equinox This SUV offers a smaller, sportier stance than the Trailblazer, all without compromising the SUV abilities.

Chevrolet Equinox
Platform: Theta

Service Stabilitrak, Traction Control lights ON, alone with check engine light...

Old October 31st, 2013, 6:42 AM
  #21  
CF Beginner
 
Join Date: Sep 2013
Posts: 11
Default

Originally it threw a code regarding the catlytic converter,replaced it all was good for a week then it threw codes running lean on left bank. cleared them a couple times, every time the check engine light came on it was always preceded by the service stabilitrac light, anyway my mechanic checked it again said it was a vacuum leak, fixed and all is good now for past 3 weeks
milehighmark is offline  
Old November 3rd, 2013, 3:36 AM
  #22  
CF Junior Member
 
wolfdogg's Avatar
 
Join Date: Apr 2011
Posts: 46
Default

ok if thats the case, and theres no codes now, then there may be a pending code, and that MAY be why the traction control light is on. I dont believe a pending code would show on the dash Service light, but it may be setting off the traction control light.

The only way to know this is to have a tester than can read pending codes. i got one at harbor freight, but i would think twice about buying one there (see this post to find out why Cen-Tech 98614 help : OBD-Codes.com) , even though it does the job well. I would get one from sears next time.

good luck!
wolfdogg is offline  
Old December 19th, 2013, 10:20 PM
  #23  
CF Beginner
 
Join Date: Dec 2013
Posts: 8
Default

FINALLY FIXED, "SERVICE STABILITRAK & TRACTION CONTROL"
DIAGNOSTIC PROBLEM:
"SERVICE STABILITRAK",
"SERVICE TRACTION CONTROL",
"HARD SHIFT 1-2 GEARS"-(STABILITRAK TURNING OFF-CLUNK NOISE)
"STABILITRAK OFF",
"TRACTION CONTROL OFF"
----------------------------------------------------------------------------------
CAUSE:
FUEL WAS 45% ETHANOL @ 85-(COSTCO GAS)-COMPUTER WENT INTO LIMP MODE CAUSING (AFM) TO GET STUCK AND NOT RESET COMPUTER.
----------------------------------------------------------------------------------
SOLUTION:
DRAINED & CLEANED GAS TANK-
CHANGED FUEL FILTERS (*ONLY IF NEEDED)
CLEANED INJECTORS-
RESET COMPUTER-
FILLED GAS TANK WITH NO ETHANOL- (Ethanol-free gas stations in the U.S. and Canada)
TOTAL AMOUNT WITH TAX: $444.86
----------------------------------------------------------------------------------

REFERENCES
(STABILITRAK CLUNK NOISE): https://chevroletforum.com/forum/sil...uestion-47580/
(AFM)-Definition: Active Fuel Management - Wikipedia, the free encyclopedia
(ETHANOL): Common ethanol fuel mixtures - Wikipedia, the free encyclopedia
(GAS STATIONS WITHOUT ETHANOL): Ethanol-free gas stations in the U.S. and Canada
nukstr is offline  
Old April 3rd, 2014, 9:58 PM
  #24  
CF Beginner
 
Join Date: Apr 2014
Location: Homewood, IL
Posts: 1
Default

Today I had the same problem with the Service Stabilitrak, Traction Control lights ON, along with check engine light. The engine went into a slow mode and would only drive about 25mph.
firemanbill44 is offline  
Old April 5th, 2014, 7:28 PM
  #25  
Official GM Rep
 
Join Date: Mar 2010
Location: Global Headquarters in Detroit, MI
Posts: 4,161
Default

Hi firemanbill44,

We're sorry to hear that you also had this concern. Please let us know if you would like for us to look further into this for you. We can be reached via private message if needed. In the message please reference your concern. We look forward to hear form you!

Kristen A.
Chevrolet Customer Care
Chevrolet Customer Service is offline  
Old June 17th, 2014, 3:43 PM
  #26  
CF Beginner
 
Join Date: Jun 2014
Posts: 3
Default Tabilitrak issues

I had some of the same issues with the message (Stabilitrak OFF) displaying at really odd times (backing into the garage, starting from a stopped position, just starting the engine) and I could not replicate the issue. So, I basically ignored it thinking the "check engine light" would eventually come on and I would take it in for service. Well, one day I started moving from a stopped position at a red light and everything on my dashboard blinked on at the same time......stabilitrak, check engine, and a bunch of other stuff that I couldn't read fast enough because the engine stopped.....in the middle of the street. I was done. It would not restart. So, as I was just sitting there in the middle of the intersection trying to find the AAA number. When AAA showed up, the tow truck drive said he could fix it fast. "just turn the key on and off 17 times and the check engine light will go off and you can start the engine." My question; did that fix the engine problem.....answer "no, it just starts the engine and you can drive it!" ARE YOU FREAKING KIDDING ME? I drove to the dealer the next day and they had an AWFUL time trying to diagnose the problem....because the 17 switches of the key reset the computer. again, ARE YOU KIDDING ME? Well, four hours later the mechanics were able to recreate the issue and found that the computer failed. It was replaced at no charge (seems that there is a 70,000 mile? warranty). THANK GOODNESS. Lesson learned....no AAA diagnosis and fix; just make them tow to the dealer.
Slovakgal is offline  
Old August 23rd, 2014, 7:05 PM
  #27  
CF Beginner
 
cknuth24's Avatar
 
Join Date: Aug 2014
Posts: 1
Default

I have a 2008 Chevy Equinox and the brakes lock up the dash says stablelink off and service traction control
cknuth24 is offline  
Old August 27th, 2014, 10:09 AM
  #28  
CF Beginner
 
Join Date: Aug 2014
Posts: 1
Default

Driving at 60 and dash lights up..service stabiltrak, abs light, traction control lights and all wheel drives.Drove to dealer and checked codes. Seems the hub was bad and piece cracked off. Most likely a MN pothole earlier in the year. Replaced hub and all is well. Jerking was from right side trying to get traction while left not reading so computer turned off systems dealing with stabilitrak, all wheel etc. Works great again.
denelsonfly is offline  
Old September 12th, 2014, 1:40 PM
  #29  
CF Beginner
 
Join Date: Sep 2014
Posts: 1
Default

I have the same year equinox having the same issue, the traction control light comes on followed by the check engine, seems to be a typical issue with this "stabiltrak" in the Chevys as I've seen the avalanches and Tahoes having the issue on other threads, is the ERG valve the typical fix for check engine light? I've yet to have the car plugged in to check why the light is on.
Btompkins26 is offline  
Old November 20th, 2014, 2:25 PM
  #30  
CF Beginner
 
Join Date: Jul 2014
Location: Champaign Il
Posts: 29
Default

Originally Posted by Btompkins26 View Post
I have the same year equinox having the same issue, the traction control light comes on followed by the check engine, seems to be a typical issue with this "stabiltrak" in the Chevys as I've seen the avalanches and Tahoes having the issue on other threads, is the ERG valve the typical fix for check engine light? I've yet to have the car plugged in to check why the light is on.


It depends. I was having the same issue with my 08 Equinox. Replaced EGR valve, cleaned tube, did tranny service, and a tune up and still getting the same codes for the EGR valve. I'm stumped, but not giving up!
momeeof2 is offline  

Thread Tools
Search this Thread
Quick Reply: Service Stabilitrak, Traction Control lights ON, alone with check engine light...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: