2005 suburban 1500 electrical issues. - Chevrolet Forum - Chevy Enthusiasts Forums

New Member Welcome Area New to CF? Stop in and introduce yourself.
This section is not for help threads.
Please introduce yourself here, but go to your model vehicle section to post questions and get answers to them. Thanks! :)

2005 suburban 1500 electrical issues.

Reply

 
 
 
Old July 10th, 2018, 9:37 PM
  #1  
CF Beginner
Thread Starter
 
Join Date: Jul 2018
Posts: 4
Default 2005 suburban 1500 electrical issues.

Hi,
i have recently purchased a 2005 suburban 1500 with 155k miles. It has most of the dash lights on like the abs,cell, security,brake,trac trac control,and tire pressure. It also says check stability. It shifts very late from 1st to 2nd and then will sometimes not downshift at a stop. Dealer replaced ebcm and battery control module problems still there. Also scan tool will not communicate with the vehicle. Any help would be greatly appreciated. Cell sometimes goes away as does the security light. All the gauges work except the Speedo and the battery gauge reads 12 when key is first turned then drops down to 9 but battery is fully charged and alternator is charging when running.
dane cole is offline  
Reply With Quote
Old July 11th, 2018, 3:26 AM
  #2  
CF Pro Member
 
oilcanhenry's Avatar
 
Join Date: Oct 2017
Location: USA
Posts: 920
Default

Originally Posted by dane cole View Post
Hi,
i have recently purchased a 2005 suburban 1500 with 155k miles. It has most of the dash lights on like the abs,cell, security,brake,trac trac control,and tire pressure. It also says check stability. It shifts very late from 1st to 2nd and then will sometimes not downshift at a stop. Dealer replaced ebcm and battery control module problems still there. Also scan tool will not communicate with the vehicle. Any help would be greatly appreciated. Cell sometimes goes away as does the security light. All the gauges work except the Speedo and the battery gauge reads 12 when key is first turned then drops down to 9 but battery is fully charged and alternator is charging when running.
You should post this in the Burb section.
oilcanhenry is offline  
Reply With Quote
Old July 11th, 2018, 6:34 PM
  #3  
CF Beginner
Thread Starter
 
Join Date: Jul 2018
Posts: 4
Default

Originally Posted by oilcanhenry View Post
You should post this in the Burb section.
Ok iI'l do that
dane cole is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: