2008 silverado windshield washer pump - Chevrolet Forum - Chevy Enthusiasts Forums
Presented by the all-new Yokoama
Presented by the all-new Yokoama

2008 silverado windshield washer pump


  Reply  
nbmech's Avatar
CF Beginner

Join Date: Aug 2012
Posts: 11

August 10th, 2012, 8:37 PM   #1  
2008 silverado windshield washer pump

Hello,
My 2008 silverado is having some electrical problems.
I parked it today at 1pm and left the area. When I returned at 6pm I heard a noise and found that the washer fluid pump was running. I also noticed tgat the daytime running lights were on, I disconnected the pump and pulled the fuse for the lights. The battery must be dead as it wont turn over. I am going to charge the battery tonight but need assistance with how to troubleshoot the problem. Any and all help is greatly appreciated!!

 
jesse06's Avatar
CF Active Member

Join Date: Jul 2006
Posts: 147
NC

August 11th, 2012, 10:37 PM   #2  
did it rain hard there? something may have been shorting out

 
Chevrolet Customer Service's Avatar
Official GM Rep

Join Date: Mar 2010
Posts: 4,161
Global Headquarters in Detroit, MI

August 13th, 2012, 2:47 PM   #3  
Posted By: nbmech Hello,
My 2008 silverado is having some electrical problems.
I parked it today at 1pm and left the area. When I returned at 6pm I heard a noise and found that the washer fluid pump was running. I also noticed tgat the daytime running lights were on, I disconnected the pump and pulled the fuse for the lights. The battery must be dead as it wont turn over. I am going to charge the battery tonight but need assistance with how to troubleshoot the problem. Any and all help is greatly appreciated!!
<!--[if gte mso 9]><xml> <w:WordDocument> <w:View>Normal</w:View> <w:Zoom>0</w:Zoom> <w:PunctuationKerning/> <w:ValidateAgainstSchemas/> <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid> <w:IgnoreMixedContent>false</w:IgnoreMixedContent> <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText> <w:Compatibility> <w:BreakWrappedTables/> <w:SnapToGridInCell/> <w:WrapTextWithPunct/> <w:UseAsianBreakRules/> <wontGrowAutofit/> </w:Compatibility> <w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel> </w:WordDocument> </xml><![endif]--><!--[if gte mso 9]><xml> <w:LatentStyles DefLockedState="false" LatentStyleCount="156"> </w:LatentStyles> </xml><![endif]--><!--[if gte mso 10]> <style> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} </style> <![endif]--> I'm sorry you are experiencing this issue with your Silverado vehicle. Would you please PM me the last 8-digits of your VIN, so I may look into this further for you?

I look forward to your reply.

Louis
GM Customer Service

 
nbmech's Avatar
CF Beginner

Join Date: Aug 2012
Posts: 11

August 14th, 2012, 8:03 PM   #4  
Hi Louis,
The last 8 #'s are 81113842.
Thanks

 
tech2's Avatar
CF Monarch

Join Date: Mar 2011
Posts: 5,095

August 14th, 2012, 8:38 PM   #5  
does it have the heated washer reservoir feature or has it been removed already?

 
nbmech's Avatar
CF Beginner

Join Date: Aug 2012
Posts: 11

August 15th, 2012, 8:00 AM   #6  
I dont think it had the heated washer if it did how do i tell??

 
tech2's Avatar
CF Monarch

Join Date: Mar 2011
Posts: 5,095

August 16th, 2012, 6:11 PM   #7  
should be a button in the center console below the hvac controls. A picture of the button should be in the owners manual.

 
nbmech's Avatar
CF Beginner

Join Date: Aug 2012
Posts: 11

August 24th, 2012, 7:18 AM   #8  
UPDATE...
It turns out the body control module, transmission control module, transfer case control module and engine control module were all bad. After talking with a neighbor he remembered hearing a close lightning strike. I guess that could have possibly caused the issue. The dealer is asking GM to assist with the repair cost.
Thanks for your help.

 
Tags
Search this Thread
Sponsors
Sponsors
Related Topics